华为网络实验--综合实验(单臂路由、OSPF+RIP、引入路由、下发默认路由、Easy IP技术)

华为综合实验

●实验目的

将某公司内部的主机通过配置单臂路由、OSPF、RIP、引入路由、Easy IP技术来实现公司内部网络能够访问互联网。

●实验拓扑图

在华为模拟器中新建如下图所示拓扑图

img

●实验步骤

1.路由器R1配置

interface GigabitEthernet0/0/0

 ip address 202.2.2.1 255.255.255.0  ##配置接口IP地址

\#

interface GigabitEthernet0/0/1

 ip address 202.2.12.1 255.255.255.0 ##配置接口IP地址

2.路由器R2配置

interface GigabitEthernet0/0/0

 ip address 10.1.113.1 255.255.255.0 ##配置接口IP地址

\#

interface GigabitEthernet0/0/2

 ip address 10.1.111.1 255.255.255.0 ##配置接口IP地址

\#

interface GigabitEthernet10/0/0

 ip address 10.1.112.1 255.255.255.0 ##配置接口IP地址

interface GigabitEthernet0/0/1

 ip address 202.2.12.2 255.255.255.0 ##配置接口IP地址

\#

interface LoopBack0

 ip address 2.2.2.2 255.255.255.255 ##配置环回IP地址

\#

ospf 1 router-id 2.2.2.2   ##配置router-id

 default-route-advertise   ##下发默认路由

 area 0.0.0.0         ##进入骨干区域0 

 network 2.2.2.2 0.0.0.0 

 network 10.1.111.0 0.0.0.255 

 network 10.1.112.0 0.0.0.255 

 network 10.1.113.0 0.0.0.255           ##宣告网段

\#

acl number 3000     ##声明规则及序号是3000

rule permit ip source 10.1.0.0 0.0.255.255

​                      ##声明出接口公网IP地址允许哪个网段使用

\#

interface GigabitEthernet0/0/1

nat outbound 3000

\#

ip route-static 0.0.0.0 0.0.0.0 202.2.12.1     ##配置数据出去的默认路由

3.路由器R3配置

interface GigabitEthernet0/0/0

 ip address 10.1.113.2 255.255.255.0 

\#

interface GigabitEthernet0/0/1

 ip address 10.1.134.1 255.255.255.0

\#

interface LoopBack0

 ip address 3.3.3.3 255.255.255.255

\#

ospf 1 router-id 3.3.3.3 

 import-route rip 1 cost 5 type 1 ##引入rip 1自治系统的路由信息

 area 0.0.0.0    ##进入骨干区域0

 network 3.3.3.3 0.0.0.0 

 network 10.1.113.0 0.0.0.255  ##宣告网段

\#

rip 1

 default-route originate ##下发默认路由

 version 2

 network 10.0.0.0

 import-route ospf 1 ##引入ospf1自治系统的路由信息

4.路由器R4配置

interface GigabitEthernet0/0/0.21

 dot1q termination vid 21

 ip address 10.1.21.1 255.255.255.0 

 arp broadcast enable   ##在子接口配置vlan 21的网关地址

\#

interface GigabitEthernet0/0/0.22

 dot1q termination vid 22

 ip address 10.1.22.1 255.255.255.0 

 arp broadcast enable ####在子接口配置vlan 22的网关地址

\#

interface GigabitEthernet0/0/1

 ip address 10.1.135.1 255.255.255.0 

\#

interface GigabitEthernet0/0/2

 ip address 10.1.134.2 255.255.255.0 

\#

interface LoopBack0

 ip address 4.4.4.4 255.255.255.255 

\#

rip 1

 version 2

 network 10.0.0.0

 network 4.0.0.0

5.路由器R5配置

interface GigabitEthernet0/0/0

 ip address 10.1.100.1 255.255.255.0 

\#

interface GigabitEthernet0/0/1

 ip address 10.1.135.2 255.255.255.0 

\#

interface LoopBack0

 ip address 5.5.5.5 255.255.255.255 

\#

rip 1

 version 2

 network 10.0.0.0

 network 5.0.0.0

6.三层交换机RSW3配置

vlan batch 11 to 12 1000 to 1001

\#

interface Vlanif11

 ip address 10.1.11.1 255.255.255.0 

\#

interface Vlanif12

 ip address 10.1.12.1 255.255.255.0 

\#

interface Vlanif1000

 ip address 10.1.122.11 255.255.255.0 

\#

interface Vlanif1001

 ip address 10.1.111.12 255.255.255.0 

\#

interface Eth-Trunk1

 port link-type access

 port default vlan 1000

\#

interface GigabitEthernet0/0/1

 port link-type access

 port default vlan 11

\#

interface GigabitEthernet0/0/2

 port link-type access

 port default vlan 12

\#

interface GigabitEthernet0/0/3

 port link-type access

 port default vlan 1001

\#

interface GigabitEthernet0/0/4

 eth-trunk 1

\#

interface GigabitEthernet0/0/5

 eth-trunk 1

\#

interface LoopBack0

 ip address 11.11.11.11 255.255.255.255 

\#

ospf 1 router-id 11.11.11.11 

 area 0.0.0.0 

 network 11.11.11.11 0.0.0.0 

 network 10.1.11.0 0.0.0.255 

 network 10.1.12.0 0.0.0.255 

 network 10.1.122.0 0.0.0.255 

 network 10.1.111.0 0.0.0.255

7.三层交换机RSW4配置

vlan batch 13 to 14 1000 1002
\#
interface Vlanif13

 ip address 10.1.13.1 255.255.255.0 
\#
interface Vlanif14

 ip address 10.1.14.1 255.255.255.0 
\#
interface Vlanif1000

 ip address 10.1.122.12 255.255.255.0 
\#
interface Vlanif1002

 ip address 10.1.112.12 255.255.255.0 
\#
interface Eth-Trunk1

 port link-type access

 port default vlan 1000
\#
interface GigabitEthernet0/0/1

 port link-type access

 port default vlan 13
\#
interface GigabitEthernet0/0/2

 port link-type access

 port default vlan 14
\#
interface GigabitEthernet0/0/3

 port link-type access

 port default vlan 1002
\#
interface GigabitEthernet0/0/4

 eth-trunk 1
\#
interface GigabitEthernet0/0/5

 eth-trunk 1
\#
interface LoopBack0

 ip address 22.22.22.22 255.255.255.255 
\#
ospf 1 router-id 22.22.22.22 

 area 0.0.0.0 

 network 22.22.22.22 0.0.0.0 

 network 10.1.112.0 0.0.0.255 

 network 10.1.122.0 0.0.0.255 

 network 10.1.14.0 0.0.0.255 

 network 10.1.13.0 0.0.0.255

8.二层交换机SW9配置

vlan batch 21 to 22

\#

interface Ethernet0/0/1

 port link-type access

 port default vlan 21

\#

interface Ethernet0/0/2

 port link-type trunk

 port trunk allow-pass vlan 21 to 22

\#

interface Ethernet0/0/3

 port link-type access

 port default vlan 22

●实验验证

公司内部网络内的主机都能成功访问互联网(下图为PC1ping通PC6)。

image-20200604151020915

●实验总结

本次实验路由器R2和R3上需要配置的命令较多,需要理清思路,仔细的配置好。

路由器R2上需要配置接口和环回地址、ospf动态路由、下发路由和数据转发到互联网的默认路由。

路由器R3上需要配置接口和环回地址、ospf动态路由、rip v2动态路由、下发路由和引入路由。

同时本次实验运用到了下发默认路由的新命令,其含义是本路由器发布一条0.0.0.0/0.0.0.0的路由到域内其他路由器。其他路由器学习到这条默认路由后,下一跳就是指向发布这条路由的路由器。

配置在网关出接口路由器上的命令:

ospf 1

default-route-advertise

配置完后ospf区域内其他路由器会多一条默认路由:

img

配置在ASBR上的命令:

rip 1

default-route originate

在rip区域内的ASBR上配置下发路由后,其他路由器会多一条默认路由:
img

已标记关键词 清除标记
<p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(255,0,0);">本课程为帮主自主研发的独门课程,根据对实际工作中的使用情况**版HCIA考试大纲HCIA考试题库题目的研究把课程分为6大模块,将近30个知识点</span><strong><span style="color:rgb(255,0,0);">【更加注重的实际运用】,</span></strong><span style="color:rgb(255,0,0);">分别如下</span><strong><span style="color:rgb(255,0,0);">:</span></strong> </p> <p style="color:rgb(66,66,66);font-size:14px;"><strong><span style="color:rgb(255,0,0);">------------------------<br /></span></strong> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(0,112,192);"><strong>【第一模块:组建简单的网络】</strong></span><span style="color:rgb(0,112,192);"><br /></span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(0,176,80);">初识网络,OSI参考模型讲解,TCP/IP协议栈上,TCP/IP协议栈下,IP地址子网划分,华为设备管理与配置</span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(0,176,80);">-------------------------------<br /></span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span><strong><span style="color:rgb(0,112,192);">【第二模块:组建中型的路由网络】</span></strong></span><span><strong><span style="color:rgb(0,112,192);"></span></strong></span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(0,176,80);">路由协议原理讲解,静态路由讲解与配置,RIP路由协议讲解与配置,OSPF路由协议讲解与配置</span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(0,176,80);">--------------------------------<br /></span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span><strong><span style="color:rgb(0,112,192);">【第三模块:组建中型的交换网络】</span></strong></span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(0,176,80);">交换机与VLAN讲解,交换与STP讲解与配置,交换与VTP讲解与配置,交换机链路聚合讲解与配置,vlan间路由讲解与配置,端口安全讲解与配置</span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(0,176,80);">---------------------------------<br /></span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span><strong><span style="color:rgb(0,112,192);">【第四模块:组建高效易用的网络】</span></strong></span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(0,176,80);">DHCP讲解与配置,DNS讲解与配置,Syslog 讲解与配置,SNMP讲解与配置,NTP讲解与配置,Wireless网络构建与配置</span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(0,176,80);">---------------------------------<br /></span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span><strong><span style="color:rgb(0,112,192);">【第五模块:组建安全的网络架构】</span></strong></span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(0,176,80);">ACL讲解与配置,防火墙讲解与配置,AAA讲解与配置</span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(0,176,80);">---------------------------------<br /></span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span><strong><span style="color:rgb(0,112,192);">【第六模块:连接到广域网链路】</span></strong></span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(0,176,80);">初识广域网PPP,HDLC,PPPOE,NAT讲解与配置,IPv6讲解与配置,GRE讲解与配置</span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(0,176,80);">----------------------------------<br /></span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span><strong><span style="color:rgb(0,112,192);">【第七模块:组建高可用的网络】</span></strong></span><span><strong><span style="color:rgb(0,112,192);"></span></strong></span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(0,176,80);">VRRP讲解与配置,SDN讲解与配置,Vxlan讲解与配置</span> </p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(0,176,80);"></span>-------------------------------- </p> <p style="color:rgb(66,66,66);font-size:14px;"><br /></p> <p style="color:rgb(66,66,66);font-size:14px;"><span style="color:rgb(192,0,0);"><strong>在这里,我不仅仅让每一位学员可以顺利通过考试,更多的是带给学员实际工作中最为常用的知识,课程中详细讲解每一个知识点的原理,并利用实验加以辅证,在课程中一直对学员强调:一定要掌握每个知识点的原理,我们不追求对命令的熟悉程度,因为我们知道我们学完该课程在实际工作中未必就一定接触的是思科的产品,所以命令再熟悉也不能体现个人的能力和价值,要想在工作中很好的体现自我价值,体现个人的能力和魅力,一定要将原理性的东西烂熟于心,否则本末倒置,得不偿失。好好学习,我会全力以赴让你赢在起跑线上。请相信我,也请相信你自己,加油!!!</strong></span> </p>
相关推荐
©️2020 CSDN 皮肤主题: 黑客帝国 设计师:白松林 返回首页