题目描述
读入两个小于100的正整数A和B,计算A+B,注意: A+B的每一位由对应的英文字母给出。
输入
测试输入包含若干测试用例,每个测试用例占一行,格式为"A + B =",相邻两字符串有一个空格间隔.当A和B同时为zero时输入结束,相应的结果不要输出.
输出
对每个测试用例输出1行,即A+B的值.
样例输入
one + two =
three four + five six =
zero + zero =
样例输出
3
90
#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<string>
using namespace std;
int fun(string i){
int j;
if(i=="zero")
return 0;
if(i=="one")
return 1;
if(i=="two")
return 2;
if(i=="three")
return 3;
if(i=="four")
return 4;
if(i=="five")
return 5;
if(i=="six")
return 6;
if(i=="seven")
return 7;
if(i=="eight")
return 8;
if(i=="nine")
return 9;
}
int main(){
int a1=0,a2=0,flag=1;
string s1;
while(cin>>s1){
if(flag==1){
a1=fun(s1);
flag=2;
}
else if(flag==2&&s1!="+"){
a1=a1*10+fun(s1);
flag=3;
}
else if(s1=="+"){
flag=3;
}
else if(flag==3){
a2=fun(s1);
flag=4;
}
else if(flag==4&&s1!="=")
{
a2=a2*10+fun(s1);
flag=4;
}else if(s1=="=")
{
if(a1==0&&a2==0)
break;
cout<<a1+a2<<endl;
flag=1;
}
}
return 0;
}
输入结果: