hdu 1228 hdoj 1228

A + B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7145    Accepted Submission(s): 4025


Problem Description
读入两个小于100的正整数A和B,计算A+B.
需要注意的是:A和B的每一位数字由对应的英文单词给出.
 

Input
测试输入包含若干测试用例,每个测试用例占一行,格式为"A + B =",相邻两字符串有一个空格间隔.当A和B同时为0时输入结束,相应的结果不要输出.
 

Output
对每个测试用例输出1行,即A+B的值.
 

Sample Input
  
  
one + two = three four + five six = zero seven + eight nine = zero + zero =
 

Sample Output
  
  
3 90 96


#include<iostream>
#include<cstring>
using namespace std;
string word[]={"zero","one","two","three","four","five","six","seven","eight","nine"};
int main(){
    string cin1,cin2;
    int result=0,A=0,B=0,forward=0,a=0,b=0;
    while(1){
        cin>>cin1>>cin2;
        for(int i=0;i<10;i++){
            if(cin1==word[i]) a=i;
            if(cin2==word[i]) b=i;
        }
        if(cin1!="+"&&cin2!="+"&&cin1!="="&&cin2!="="){
            if(forward==0){
                A=10*(10*A+a)+b;
            }
            else{
                B=10*(10*B+a)+b;
            }
        }
        else if(cin1=="+"){
            result+=A;
            B=10*B+b;
            forward=1;
        }
        else if(cin2=="+"){
            A=10*A+a;
            result+=A;
            forward=1;
        }
        else if(cin1=="="){
            result+=B;
            if(result==0) break;
            cout<<result<<endl;
            result=0,forward=0;
            A=0,B=0;
            A=10*A+b;
        }
        else if(cin2=="="){
            B=10*B+a;
            result+=B;
            if(result==0) break;
            cout<<result<<endl;
            result=0,forward=0,A=0,B=0;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值