Constraints
Time Limit: 3 secs, Memory Limit: 32 MB
Description
Given a sequence of consecutive integers n,n+1,n+2,...,m, an anti-prime sequence is a rearrangement of these integers so that each adjacent pair of integers sums to a composite (non-prime) number. For example, if n = 1 and m = 10, one such anti-prime sequence is 1,3,5,4,2,6,9,7,8,10. This is also the lexicographically first such sequence. We can extend the definition by defining a degree danti-prime sequence as one where all consecutive subsequences of length 2,3,...,d sum to a composite number. The sequence above is a degree 2 anti-prime sequence, but not a degree 3, since the subsequence 5, 4, 2 sums to 11. The lexicographically .rst degree 3 anti-prime sequence for these numbers is 1,3,5,4,6,2,10,8,7,9.
Input
Input will consist of multiple input sets. Each set will consist of three integers, n, m, and d on a single line. The values of n, m and d will satisfy 1 <= n < m <= 1000, and 2 <= d <= 10. The line 0 0 0 will indicate end of input and should not be processed.
Output
For each input set, output a single line consisting of a comma-separated list of integers forming a degree danti-prime sequence (do not insert any spaces and do not split the output over multiple lines). In the case where more than one anti-prime sequence exists, print the lexicographically first one (i.e., output the one with the lowest first value; in case of a tie, the lowest second value, etc.). In the case where no anti-prime sequence exists, output No anti-prime sequence exists.
Sample Input
1 10 2 1 10 3 1 10 5 40 60 7 0 0 0
Sample Output
1,3,5,4,2,6,9,7,8,10 1,3,5,4,6,2,10,8,7,9 No anti-prime sequence exists. 40,41,43,42,44,46,45,47,48,50,55,53,52,60,56,49,51,59,58,57,54
1000个数的全排列太大了,用搜索好像又会超时。但仔细分析又发现,条件比较苛刻,all consecutive subsequences of length 2,3,...,d sum to a composite number,也就是说,从2到d的子序列都要满足,不单单d长度的。 /*我一开始理解错了*/ 这样的话,能大量剪枝,保证不会超时。而且只需找到一个字典序最小的解,也提示我们应该是按字典序进行深搜、
#include <iostream>
#include <memory.h>
using namespace std;
int n,m,d;
bool used[1005];
bool finds;
bool isprime[10005];
int seq[1005];
void makeprime()
{
memset(isprime,1,sizeof(isprime));
isprime[0]=0;
isprime[1]=0;
for (int i = 2; i < 10005; ++i)
{
/* code */
if(isprime[i])
{
for (int j=i*i; j< 10005; j+=i)
{
/* code */
isprime[j]=0;
}
}
}
}
bool check_prime(int depth, int num)
{
int sum=num;
for (int i = 2; i<=d &&depth-i+1>0; ++i)
{
/* code */
sum+=seq[depth-i+1];//这里又错了一遍....
if(isprime[sum])
{
return false;
}
}
return true;
}
void search(int depth)
{
if(depth>m-n+1)
{
finds=true;
cout<<seq[1];
for (int i = 2; i <= m-n+1; ++i)
{
/* code */
cout<<","<<seq[i];
}
cout<<endl;
return ;
}
for (int i = n; i <=m && !finds ; ++i)
{
/* code */
if(!used[i])
{
if(check_prime(depth,i))
{
seq[depth]=i;
used[i]=true;
search(depth+1);
used[i]=false;
}
}
}
}
int main()
{
makeprime();
while(cin>>n>>m>>d&&(n+m+d!=0))
{
memset(seq,0,sizeof(seq));
memset(used,0,sizeof(used));
finds=0;
for (int i = n; i<=m && !finds; ++i)
{
/* code */
used[i]=1;
seq[1]=i; //very important ...no forget
search(2);
used[i]=0;
}
if(!finds)
cout<<"No anti-prime sequence exists."<<endl;
}
}