1002.Anti-prime Sequences

Input:

Input will consist of multiple input sets. Each set will consist of three integers, n, m, and d on a single line. The values of n, m and d will satisfy 1 <= n < m <= 1000, and 2 <= d <= 10. The line 0 0 0 will indicate end of input and should not be processed.

Output:

For each input set, output a single line consisting of a comma-separated list of integers forming a degree danti-prime sequence (do not insert any spaces and do not split the output over multiple lines). In the case where more than one anti-prime sequence exists, print the lexicographically first one (i.e., output the one with the lowest first value; in case of a tie, the lowest second value, etc.). In the case where no anti-prime sequence exists, output No anti-prime sequence exists.

Sample Input

1 10 2
1 10 3
1 10 5
40 60 7
0 0 0

Sample Output

1,3,5,4,2,6,9,7,8,10
1,3,5,4,6,2,10,8,7,9
No anti-prime sequence exists.
40,41,43,42,44,46,45,47,48,50,55,53,52,60,56,49,51,59,58,57,54
例如:输入是1 10 2的时候
表示的是: 在 1 到 10 之间, 要保证这个数列的任意两个相邻的数字的和是合数
若是1 10 3
则表示的是任意相邻的三个数字之间的和是合数

代码实现:

// 这道题目用到了深度优先搜索,参考了网上的解法
#include<iostream>
#include<cmath>
#include<cstring>
using namespace std;

int n, m, d;
int arr[1010], vis[1010], flag;
int is_prime(int num) {
    for (int i = 2; i <= sqrt(num); ++i) 
        if (num % i == 0) return 0; 
    return 1;
}
int verify(int cur, int num) {
    for (int i = cur - 1; i >= 0 && i >= cur - d + 1; --i) {
        num += arr[i];
        if (is_prime(num))
            return 0; 
    }
    return 1;
}
void dfs(int cur) {
    for (int i = n; i <= m; ++i) {
        if (!vis[i] && verify(cur, i)) {
            vis[i] = 1;
            arr[cur] = i;
            if (cur == m - n) {
                flag = 1;
                return;
            }
            dfs(cur + 1);
            if (flag) return;
            vis[i] = 0;
        }
    }
}
int main() {
    while (cin >> n >> m >> d && n) {
        flag = 0;
        memset(vis, 0, sizeof(vis));
        dfs(0);
        if (flag) {
            cout << arr[0];
            for (int i = 1; i <= m - n; ++i)
                cout << "," << arr[i];
            cout << endl;
        } else {
            cout << "No anti-prime sequence existd." << endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值