1014 Waiting in Line (30)

题目描述

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
Customer[i] will take T[i] minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer~1~ is served at window~1~ while customer~2~ is served at window~2~. Customer~3~ will wait in front of window~1~ and customer~4~ will wait in front of window~2~. Customer~5~ will wait behind the yellow line.

At 08:01, customer~1~ is done and customer~5~ enters the line in front of window~1~ since that line seems shorter now. Customer~2~ will leave at 08:02, customer~4~ at 08:06, customer~3~ at 08:07, and finally customer~5~ at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output “Sorry” instead.

Sample Input

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output

08:07
08:06
08:10
17:00
Sorry

解题思路

还是老样子,把时间转化为距离零点的分钟数,最后输出的时候再转化回来;整个处理过程可分为3个阶段:

  • 把窗口队列尽量填满(此过程不服务顾客)
  • 开始选择窗口进行顾客服务,服务一个,从等候区里再添加一个顾客到该窗口队列中,循环此过程
  • 窗口队列排空:对每个窗口的队列中的顾客进行服务,不同的窗口忽略先后顺序,没有影响

注意事项

如果在17:00前就被服务的,即使结束时间在17:00之后,也不会输出sorry,只有在17:00及之后的时间被服务的才会输出sorry

代码

#include<iostream>
#include<string>
#include<vector>
#include<queue>
#include<climits>
using namespace std;

int limit;
struct Window {
    queue<int>q;
    int time;
    Window() {
        time = 8 * 60;
    }
};


int lineInitial( int k, vector<Window>&win_list);
void waitProcess(int number, int*ctm_list, int k, vector<Window>&win_list);
void emptying(int*ctm_list, int k, vector<Window>&win_list);
string timeProcess(int*ctm_list, int n,int *cost_time);
int main() {
    int n, m, k, q, i, rmnum;
    cin >> n >> m >> k >> q;
    limit = m;

    Window window;
    int *ctm_list = new int[k];
    int*cost_time = new int[k];
    vector<Window>win_list;
    int *queries = new int[q];

    for (i = 0; i < k; i++) {
        cin>>ctm_list[i];
        cost_time [i]= ctm_list[i];
    }
    for (i = 0; i < q; i++) {
        cin >> queries[i];
    }
    for (i = 0; i < n; i++) {
        win_list.push_back(window);
    }

    rmnum = lineInitial(k, win_list);
    waitProcess(rmnum, ctm_list, k, win_list);
    emptying(ctm_list, k, win_list);

    for (i = 0; i < q-1; i++) {
        cout << timeProcess(ctm_list, queries[i]-1,cost_time) << endl;
    }
    cout << timeProcess(ctm_list, queries[i]-1, cost_time);
}

/*最开始的时候将每个窗口依次填充顾客*/
int lineInitial(int k, vector<Window>&win_list) {
    int i;
    int idx;
    for (i = 0; i < k; i++) {
        idx = i%win_list.size();
        if (win_list[idx].q.size() != limit) {
            win_list[idx].q.push(i);
        }
        else
            break;
    }
    return i;
}

/*若lineInitial之后窗口满了,则需要开始处理Line内的顾客
  ,每处理一个顾客,往该队列中再加入等候区的一个顾客,直到
  等候区一个人也没有
 */
void waitProcess(int number, int*ctm_list, int k, vector<Window>&win_list) {
    int i, j;
    int mintime, minidx;
    for (i = number; i < k; i++) {
        mintime = INT_MAX;
        minidx = 0;
        for (j = 0; j < win_list.size(); j++) {
            if (mintime > win_list[j].time+ctm_list[win_list[j].q.front()]) {
                mintime = win_list[j].time + ctm_list[win_list[j].q.front()];
                minidx = j;
            }
        }
        win_list[minidx].time += ctm_list[win_list[minidx].q.front()];
        ctm_list[win_list[minidx].q.front()] = win_list[minidx].time;
        win_list[minidx].q.pop();

        win_list[minidx].q.push(i);
    }
}

/*对窗口队列进行排空处理*/
void emptying(int*ctm_list, int k, vector<Window>&win_list) {
    int i;
    for (i = 0; i < win_list.size(); i++) {
        while (!win_list[i].q.empty()) {
            win_list[i].time += ctm_list[win_list[i].q.front()];
            ctm_list[win_list[i].q.front()] = win_list[i].time;
            win_list[i].q.pop();
        }
    }

}
string timeProcess(int*ctm_list, int n,int*cost_time) {
    int hour, minute;
    string time = "";
    if (ctm_list[n] - cost_time[n]>=60 * 17) {
        time = "Sorry";
    }
    else {
        hour = ctm_list[n] / 60;
        minute = ctm_list[n] % 60;

        time += (hour / 10) + '0';
        time += (hour % 10) + '0';
        time += ':';
        time += (minute / 10) + '0';
        time += (minute % 10) + '0';
    }

    return time;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值