[HDU 1505 City Game] HDU1506加强版

15 篇文章 0 订阅

题目链接  http://acm.hdu.edu.cn/showproblem.php?pid=1505

City Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5711    Accepted Submission(s): 2464


Problem Description
Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.
 

Input
The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:

R – reserved unit

F – free unit

In the end of each area description there is a separating line.
 

Output
For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.
 

Sample Input
  
  
2 5 6 R F F F F F F F F F F F R R R F F F F F F F F F F F F F F F 5 5 R R R R R R R R R R R R R R R R R R R R R R R R R
 

Sample Output
  
  
45 0
 

Source
 

简单的dp吧。。稍微想一下就行了,处理一下它给的图,例如第一个样例可以处理成

011111
122222
000333
111444
222555
开一个数组dp[i][j],每一行遍历一次,若是F,就加上上一行的dp值,求出连续F的个数,若遇到R就归0

如下:

for (int i = 1; i <= n; i++)
{
	for (int j = 1; j <= m; j++)
	{
		if (map[i][j] == 'R')
		dp[i][j] = 0;
		else dp[i][j] = dp[i - 1][j] + 1;
	}
}
得出每一行的数列后,就可以发现这题和HDU1506一毛一样,只是1506求一行,这题要求多行并取最大值

HDU 1506 题解 http://blog.csdn.net/chenninggo/article/details/48080271

注意下输入,因为卡输入wa了几次,也算是学到了特殊的输入技巧

代码如下。。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int t;
int n, m;
char map[1010][1010], ch[5];
int dp[1010][1010], l[1010], r[1010];
int main()
{
//  freopen("input.txt", "r", stdin);
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d%d", &n, &m);
		for (int i = 1; i <= n; i++)            //这种输入法真的好好用。。
			for (int j = 1; j <= m; j++)
			{
				scanf("%s", ch);
				map[i][j] = ch[0];
			}
		memset(dp, 0, sizeof(dp));
		for (int i = 1; i <= n; i++)         //处理一下原图
		{
			for (int j = 1; j <= m; j++)
			{
				if (map[i][j] == 'R')
					dp[i][j] = 0;
				else dp[i][j] = dp[i - 1][j] + 1;
			}
		}
		int ans = -1, mx, id;
		for (int i = 1; i <= n; i++)
		{
			memset(l, 0, sizeof(l));
			memset(r, 0, sizeof(r));
			l[1] = 1;
			r[m] = m;
			for (int j = 2; j <= m; j++)             //和1506一样的方法
			{
				id = j;
				while (id > 1 && dp[i][j] <= dp[i][id - 1])
					id = l[id - 1];
				l[j] = id;
			}
			for (int j = m - 1; j >= 1; j--)
			{
				id = j;
				while (id < m && dp[i][j] <= dp[i][id + 1])
					id = r[id + 1];
				r[j] = id;
			}
			mx = -1;
			for (int j = 1; j <= m; j++)
				mx = max(mx, (r[j] - l[j] + 1)*dp[i][j]);
			ans = max(mx, ans);
		}
		printf("%d\n", ans * 3);
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值