[HDU 5375 Gray code] 15多校赛DP

15 篇文章 0 订阅

题目链接 http://acm.hdu.edu.cn/showproblem.php?pid=5375

Gray code

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 866    Accepted Submission(s): 496


Problem Description
The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious output from electromechanical switches. Today, Gray codes are widely used to facilitate error correction in digital communications such as digital terrestrial television and some cable TV systems.



Now , you are given a binary number of length n including ‘0’ , ’1’ and ‘?’(? means that you can use either 0 or 1 to fill this position) and n integers(a1,a2,….,an) . A certain binary number corresponds to a gray code only. If the ith bit of this gray code is 1,you can get the point ai.
Can you tell me how many points you can get at most?

For instance, the binary number “00?0” may be “0000” or “0010”,and the corresponding gray code are “0000” or “0011”.You can choose “0000” getting nothing or “0011” getting the point a3 and a4.
 

Input
The first line of the input contains the number of test cases T.

Each test case begins with string with ‘0’,’1’ and ‘?’.

The next line contains n (1<=n<=200000) integers (n is the length of the string).

a1 a2 a3 … an (1<=ai<=1000)
 

Output
For each test case, output “Case #x: ans”, in which x is the case number counted from one,’ans’ is the points you can get at most
 

Sample Input
  
  
2 00?0 1 2 4 8 ???? 1 2 4 8
 

Sample Output
  
  
Case #1: 12 Case #2: 15
Hint
https://en.wikipedia.org/wiki/Gray_code http://baike.baidu.com/view/358724.htm
 

Author
UESTC
 

Source
2015 Multi-University Training Contest 7

题意:给你由1、0、?组成的二进制数,?可以是0也可以是1,根据给你的二进制数可以求出这个二进制数的格雷码,题目再给你二进制数每一位的权值,求出权值相加和最大的答案

比如样例00?0,这个二进制数可以为0010,也可以为0000。那么对应的格雷码分别是0011和0000,对应每位的权值是1,2,4,8。那么可以得知对应的答案分别是0*1+0*2+1*4+1*8=12和0*1+0*2+0*4+0*8=0。显而易见,答案是12。

关于格雷码的求法:
下标12345
二进制数11011
开个数组,每一位存0或者1
二进制数a[6],储存二进制数11011
格雷码数b[6],
第一位不变,b[1]=a[1];
第二位开始,b[i]=a[i-1]^a[i];
由此可得二进制数11011的格雷码是10110

  当初比赛丝毫没有思路。。经过学长提醒才知道这是dp。。学习了

想明思路后感觉还是简单的,重点是如何使用dp

开二维数组 dp[n][2],dp[i][0]表示该位为0时的权值和,dp[i][1]表示该位为1时的权值和。那么当下标 i 为?时,分别取0或1,与i-1位进行操作运算,取最大值保存即可

具体看代码。。

代码虽然长了点,但很好理解

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[200001][2];
char a[200001];
int w[200001];
int n;
int main()
{
    //    freopen("input.txt", "r", stdin);
    scanf("%d", &n);
    int cases = 1;
    for (cases = 1; cases <= n; cases++)
    {
        scanf("%s", a);  //输入二进制数
        int len = strlen(a);  //取位数
        for (int i = 0; i < len; i++)  //根据位数输入每一位对应的权值
        {
            scanf("%d", &w[i]);
            dp[i][0] = dp[i][1] = 0;  //初始化dp值
        }
        if (a[0] == '?')  //特判一下,当第一位就为?时,取1时,加上该位的权值,取0则不加
        {
            dp[0][1] = w[0];
            dp[0][0] = 0;
        }
        else{            //依旧是特判第一位
            if (a[0] - '0' == 0)  
                dp[0][0] = 0;
            else dp[0][1] = w[0];
        }
        for (int i = 1; i < len; i++)
        {
            if (a[i] == '?')  //当当前位为?时
            {
                if (a[i - 1] == '1'){      //并且当 i-1 位为1时
                    dp[i][0] = dp[i - 1][1] + w[i];   //?取0的时候,加上权值
                    dp[i][1] = dp[i - 1][1];          //?取1的时候,不加权值
                }
                else if (a[i - 1] == '0'){ //并且当 i-1 位为0时 
                    dp[i][0] = dp[i - 1][0];          //?取0的时候,不加权值
                    dp[i][1] = dp[i - 1][0] + w[i];   //?取1的时候,加上权值
                }
                else {                     //并且当 i-1 位为?时
                    dp[i][0] = max(dp[i - 1][0], dp[i - 1][1] + w[i]);
                    dp[i][1] = max(dp[i - 1][0] + w[i], dp[i - 1][1]);
                }
            }
            else if (a[i] == '0')          //同上  
            {
                if (a[i - 1] == '1'){
                    dp[i][0] = dp[i - 1][1] + w[i];
                }
                else if (a[i - 1] == '0'){
                    dp[i][0] = dp[i - 1][0];
                }
                else {
                    dp[i][0] = max(dp[i - 1][0], dp[i - 1][1] + w[i]);
                }
            }
            else                           //同上
            {
                if (a[i - 1] == '1'){
                    dp[i][1] = dp[i - 1][1];
                }
                else if (a[i - 1] == '0'){
                    dp[i][1] = dp[i - 1][0] + w[i];
                }
                else {
                    dp[i][1] = max(dp[i - 1][0] + w[i], dp[i - 1][1]);
                }
            }
        }
        int ans;
        len -= 1;
        if (a[len] == '0')
            printf("Case #%d: %d\n", cases, dp[len][0]);
        else if (a[len] == '1')
            printf("Case #%d: %d\n", cases, dp[len][1]);
        else{
            ans = max(dp[len][0], dp[len][1]);   //取最大值输出即可
            printf("Case #%d: %d\n", cases, ans);
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值