[HDU 1171 Big Event in HDU]背包

15 篇文章 0 订阅
6 篇文章 0 订阅

题目链接 http://acm.hdu.edu.cn/showproblem.php?pid=1171

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29717    Accepted Submission(s): 10424


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
  
  
20 10 40 40
 

Author
lcy
 
n行数,每行2个数字,代表价值和数量,让你尽可能的平分,并且前者价值要大于等于后者,两者的差要尽可能的小。

先求出总价值sum,sum/2就是后者背包的体积,往里面塞,尽可能塞满,就是01背包的做法,最后的答案就是sum-dp[sum/2]和dp[sum/2]

注意n为负数就中止程序

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int sum, n;
int val[250005], dp[250005];
int cnt;
void init()
{
	memset(dp, 0, sizeof(dp));
	memset(val, 0, sizeof(val));
	sum = 0;
	cnt = 1;
}
int main()
{
//	freopen("input.txt", "r", stdin);
	while (scanf("%d", &n) != EOF&&n > 0)
	{
		int v, t;
		init();
		for (int i = 1; i <= n; i++)
		{
			scanf("%d%d", &v, &t);
			for (int j = 1; j <= t; j++)
			{
				sum += v;
				val[cnt++] = v;
			}
		}
		cnt--;
		for (int i = 1; i <= cnt; i++)
			for (int j = sum / 2; j >= 0; j--)
				if (j - val[i] >= 0)
					dp[j] = max(dp[j], dp[j - val[i]] + val[i]);
		printf("%d %d\n", sum - dp[sum / 2], dp[sum / 2]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值