S-Nim
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 4644 | Accepted: 2431 |
Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:
recently learned an easy way to always be able to find the best move:
Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S = {2, 5} each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?
your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
- The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.
- The players take turns chosing a heap and removing a positive number of beads from it.
- The first player not able to make a move, loses.
recently learned an easy way to always be able to find the best move:
- Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).
- If the xor-sum is 0, too bad, you will lose.
- Otherwise, move such that the xor-sum becomes 0. This is always possible.
- The player that takes the last bead wins.
- After the winning player's last move the xor-sum will be 0.
- The xor-sum will change after every move.
Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S = {2, 5} each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?
your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
Input
Input consists of a number of test cases.
For each test case: The first line contains a number k (0 < k ≤ 100) describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps.
The last test case is followed by a 0 on a line of its own.
For each test case: The first line contains a number k (0 < k ≤ 100) describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps.
The last test case is followed by a 0 on a line of its own.
Output
For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'.
Print a newline after each test case.
Print a newline after each test case.
Sample Input
2 2 5 3 2 5 12 3 2 4 7 4 2 3 7 12 5 1 2 3 4 5 3 2 5 12 3 2 4 7 4 2 3 7 12 0
Sample Output
LWW WWL下面展示ac代码
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
int bz[105];
int sg[10050];
int mes[10050];
void getsg(int x)
{
int a;
memset(sg, 0, sizeof(sg));
for (int s = 0; s <10010; s++)//相当于打一个表~~在允许的步骤(bz数组存储)下~从0到10010的所有数量代表的sg数先预处理出来
{
memset(mes, 0, sizeof(mes));//mes用来找小于s的所有sg函数的值组成的序列里,最小的没出现过整数(从0开始)
for (a = 0; a<x; a++)
{
if (s - bz[a] >= 0)我曾经试着用sort先处理bz数组,这样就不用每次判断,可是忘了sort本身就很慢;
{
mes[sg[s - bz[a]]] = 1;
}
}
for (a = 0; a < 10010; a++)
{
if (mes[a] == 0)
{
sg[s] = a;//找到最小的没出现的
break;
}
}
}
}
int main()
{
ios::sync_with_stdio(false);
int bzz;
while (cin >> bzz&&bzz)
{
for (int s = 0; s < bzz; s++)
{
cin >> bz[s];
}
getsg(bzz);
int te;
cin >> te;
queue<char>an;//用来储存答案,也有人用string存储。
while (te--)
{
int jg;
cin >> jg;
int ans = 0;
for (int s = 0; s < jg; s++)
{
int h;
cin >> h;
ans = ans^sg[h];
}
if (ans == 0)
{
//cout << "L";
an.push('L');
}
else
{
an.push('W');
}
}
while (!an.empty())
{
cout << an.front();
an.pop();
}
cout << endl;
}
return 0;
}