题目描述
假设有向图G采用邻接表存储,设计算法求出图G中每个顶点的出度。
输入
第一行为图中顶点的个数n 第二行为图的边的条数e 第三行为依附于一条边的两个顶点的数据信息。
输出
图G中每个顶点的出度。第一行表示顶点0的出度,其他行定义相同。
样例输入
5
6
0 1
0 3
1 2
1 3
4 0
4 3
样例输出
2
2
0
0
2
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
const int N = 10010;
int h[N], e[N], ne[N], idx;
void add(int a, int b)
{
e[idx] = b;
ne[idx] = h[a];
h[a] = idx++;
}
void iterate(int u)
{
int cnt = 0;
for(int id = h[u]; id != -1; id = ne[id])
cnt++;
cout<<cnt<<endl;
}
int main()
{
int n, m;
cin>>n>>m;
memset(h,-1,sizeof h);
while(m--)
{
int x, y;
cin>>x>>y;
add(x, y);
}
for(int u = 0; u < n; u++)
iterate(u);
return 0;
}