nyoj218 Dinner

Dinner

时间限制: 100 ms  |            内存限制: 65535 KB
难度: 1
描述
Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.
输入
There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.
输出
For each test of the input, output all the name of tableware.
样例输入
3 basketball fork chopsticks
2 bowl letter
样例输出
fork chopsticks
bowl
提示
The tableware only contains: bowl, knife, fork and chopsticks.
做大贪心头疼死了,本想做个小贪的...真醉了。南阳逗我啊,这哪里是贪心???本人不才,就这样过了。
#include<stdio.h>
#include<string.h>
int main()
{
    int n;
    int i;//循环变量 
    int t;//控制空格变量 
    int a[1010];
    char s[1010][20];
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<n;i++)
        {
            scanf("%s",s[i]);
            a[i]=0;
            if(strcmp(s[i],"fork")==0||strcmp(s[i],"bowl")==0||strcmp(s[i],"knife")==0||strcmp(s[i],"chopsticks")==0)
            {
                a[i]=1;
            }
        }
        t=0;
        for(i=0;i<n;i++)
        {
            if(a[i]==1)
            {
                if(t>0)
                {
                    printf(" ");
                }
                printf("%s",s[i]);
                t++;
            }
        }
        printf("\n");
    }
    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值