hdoj 1052 Tian Ji -- The Horse Racing

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19389    Accepted Submission(s): 5672


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
  
  
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
  
  
200 0 0
 刚看贪心那会,见这题就不敢去做,今天a出来了。
/*n匹马的n次比赛,这个过程过于复杂,为了简化过程,我们可以把这个过程分割成很多阶段*/ 
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
    int n,i,j;
    int tj[1100],tjwin;//田忌的马和他胜的局数 
    int king[1100],kingwin;//国王的马和他胜的局数 
    int tjfast,tjslow,kingslow,kingfast;//分别记录每个阶段田忌和国王的最快的马和最慢的马 
    while(scanf("%d",&n)&&(n!=0))
    {
        for(i=0;i<n;i++)
        {
            scanf("%d",&tj[i]);
        }
        for(i=0;i<n;i++)
        {
            scanf("%d",&king[i]);
        }
        sort(tj,tj+n);//按马匹速度升序排列 
        sort(king,king+n);
        tjwin=kingwin=0; 
        tjfast=kingfast=n-1;tjslow=kingslow=0;//记录最快最慢的马 
        /*每次让田忌该阶段最慢的马和国王最慢的马相比
        情况有三:
        一:田忌马比国王快,必赢,继续下匹马的比较  结果赢 
        二:田忌马比国王慢,和国王任意马都输,还不如消耗国王最快的马,让它与国王最快的马比赛 结果输 
        三:一样快,比较最快的马:
                   若田忌快马比国王的快,直接比赛 结果赢    
                   否则让慢马与国王快马比赛 思想还是消耗国王最快的马 结果输*/
         for(i=0;i<n;i++)
         {
             if(tj[tjslow]>king[kingslow])
             {
                 tjwin++;//田忌胜 
                 tjslow++;kingslow++;//进行下一阶段慢马比较 
             }
             else if(tj[tjslow]<king[kingslow])
             {
                 kingwin++;
                 tjslow++;kingfast--;//用最慢的马消耗了国王最快的马 
             }
             else
             {
                 if(tj[tjfast]>king[kingfast])
                 {
                     tjwin++;
                     tjfast--;kingfast--;//进行下一阶段慢马比较 
                 }
                 else 
                 {
                     if(tj[tjslow]<king[kingfast])//只有最慢的马慢于国王最快的马 国王才赢 第二组测试数据......无奈啊 
                     {
                          kingwin++;
                          tjslow++;kingfast--;//消耗国王最快的马 
                     }
                 } 
             } 
         }
         printf("%d\n",200*(tjwin-kingwin));
    }
    return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值