hdoj 1083 Courses

Courses

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4072    Accepted Submission(s): 1942


Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 

Sample Input
  
  
2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1
 

Sample Output
  
  
YES NO
 
本题要求每门课程至少有一个学生且不能重复。有两种思路:
一:只需求出总课程的最大匹配数,若等于总课程数输出YES,反之输出NO
二:遍历所有课程,若有课程匹配不上,输出NO,反之输出YES
但一切建立在find函数的前提下!!!
代码实现匈牙利算法:
#include<stdio.h>
#include<string.h>
#define max 1000+10
int used[max],map[max][max],course[max];
int p,n;
int find(int x)
{
    int i;
    for(i=1;i<=n;i++)
    {
        if(map[x][i]&&used[i]==0)
        {
            used[i]=1;
            if(course[i]==0||find(course[i]))
            {
                course[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int t,i,j;
    int num,a,exist;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&p,&n);
        memset(map,0,sizeof(map));
        memset(course,0,sizeof(course));
        for(i=1;i<=p;i++)
        {
            scanf("%d",&num);
            while(num--)
            {
                scanf("%d",&a);
                map[i][a]=1;
            }
        }
        //思路一: 
        exist=0;
        for(i=1;i<=p;i++)
        {
            memset(used,0,sizeof(used));
            if(find(i))
            exist++;
        }
        if(exist==p)
        printf("YES\n");
        else
        printf("NO\n");
        //思路二: 
        /*exist=1;
        for(i=1;i<=p;i++)
        {
            memset(used,0,sizeof(used));
            if(find(i)==0)
            {
                exist=0;
                break;
            }
        }
        if(exist)
        printf("YES\n");
        else
        printf("NO\n");*/
    }
    return 0;
}

 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值