hdoj 3592 World Exhibition 【差分约束】【基础题】



World Exhibition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1357    Accepted Submission(s): 662


Problem Description
Nowadays, many people want to go to Shanghai to visit the World Exhibition. So there are always a lot of people who are standing along a straight line waiting for entering. Assume that there are N (2 <= N <= 1,000) people numbered 1..N who are standing in the same order as they are numbered. It is possible that two or more person line up at exactly the same location in the condition that those visit it in a group.

There is something interesting. Some like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of X (1 <= X <= 10,000) constraints describes which person like each other and the maximum distance by which they may be separated; a subsequent list of Y constraints (1 <= Y <= 10,000) tells which person dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between person 1 and person N that satisfies the distance constraints.
 

Input
First line: An integer T represents the case of test.

The next line: Three space-separated integers: N, X, and Y.

The next X lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= N. Person A and B must be at most C (1 <= C <= 1,000,000) apart.

The next Y lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= C. Person A and B must be at least C (1 <= C <= 1,000,000) apart.
 

Output
For each line: A single integer. If no line-up is possible, output -1. If person 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between person 1 and N.
 

Sample Input
  
  
1 4 2 1 1 3 8 2 4 15 2 3
 

Sample Output
  
  
19
 
题意:有N个人排成一条直线,给出X+Y个限制,X限制表明第a个人和第b个人最多相差c,Y限制表明第a个人和第b个人最少相差c。问你能否求出第一个人和第N个人最多相差多少距离,若不存在最大距离输出-1,若两人距离可以任意输出-2,否则输出最大距离。(同一个位置可以有多个人)


简单差分约束
建边有三条:S[i] 表示第i个人与第一个人距离。

1,S[b] - S[a] <= c
2,S[b] - S[a] >= c
3,S[i+1] - S[i] >= 0 (1 <= i <= N-1)

AC代码:


#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#define MAXN 1000+10
#define MAXM 50000+10
#define INF 10000000
using namespace std;
struct Edge
{
	int from, to, val, next;
}edge[MAXM];
int dist[MAXN], used[MAXN];
int head[MAXN], top;
bool vis[MAXN];//标记是否入队
int N, X, Y;
void init() 
{
	top = 0;
	memset(head, -1, sizeof(head));
}
void addEdge(int u, int v, int w)
{
	Edge E = {u, v, w, head[u]};
	edge[top] = E;
	head[u] = top++;
}
void getMap()
{
	int a, b, c;
	for(int i = 1; i < N; i++)
	addEdge(i+1, i, 0);
	while(X--)
	{
		scanf("%d%d%d", &a, &b, &c);
		addEdge(a, b, c);
	}
	while(Y--)
	{
		scanf("%d%d%d", &a, &b, &c);
		addEdge(b, a, -c);
	}
}
void SPFA()
{
	queue<int> Q;
	for(int i = 1; i <= N; i++)
	{
		dist[i] = i==1 ? 0 : INF;
		used[i] = i==1 ? 1 : 0;
		vis[i] = i==1 ? true : false;
	}
	Q.push(1);
	while(!Q.empty())
	{
		int u = Q.front();
		Q.pop();
		vis[u] = false;
		for(int i = head[u]; i != -1; i = edge[i].next)
		{
			Edge E = edge[i];
			if(dist[E.to] > dist[u] + E.val)
			{
				dist[E.to] = dist[u] + E.val;
				if(!vis[E.to])
				{
					vis[E.to] = true;
					used[E.to]++;
					if(used[E.to] > N)//负环 
					{
						printf("-1\n");
						return ;
					} 
					Q.push(E.to);
				}
			} 
		}
	}
	if(dist[N] == INF)//任意大 
	printf("-2\n");
	else
	printf("%d\n", dist[N]);
}
int main()
{
	int t;
	scanf("%d", &t);
	while(t--)
	{
		scanf("%d%d%d", &N, &X, &Y);
		init();
		getMap();
		SPFA();
	}
	return 0;
} 








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值