poj 3159 Candies 【简单差分约束】 【SPFA + 数组模拟栈】

Candies
Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 25010 Accepted: 6783

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 throughN. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.


题意:有n个孩子,给出m个限制a b c 即b孩子的糖果最多比a孩子多c个。让你求出第n个孩子最多比第一个孩子多多少糖果。


差分约束基础题,只不过用SPFA + queue 会TLE,可以直接用数目模拟栈。


AC代码:496ms


#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <algorithm>
#define MAXN 30000+10
#define MAXM 150000+10
#define INF 10000000
using namespace std;
struct Edge
{
	int from, to, val, next;
}edge[MAXM];
int head[MAXN], edgenum;
int dist[MAXN];
int used[MAXN];
bool vis[MAXN];
int S[MAXN];//模拟栈 
int n, m;
void init()
{
	edgenum = 0;
	memset(head, -1, sizeof(head));
} 
void addEdge(int u, int v, int w)
{
	Edge E = {u, v, w, head[u]};
	edge[edgenum] = E;
	head[u] = edgenum++;
}
void getMap()
{
	int a, b, c;
	while(m--)
	{
		scanf("%d%d%d", &a, &b, &c);
		addEdge(a, b, c);
	}
}
void SPFA()
{
	int top = 0;
	for(int i = 1; i <= n; i++)
	{
		dist[i] = INF;
		vis[i] = false;
	}
	vis[1] = true;
	dist[1] = 0;
	S[top++] = 1;
	while(top)
	{
		int u = S[--top];
		vis[u] = false;
		for(int i = head[u]; i != -1; i = edge[i].next)
		{
			Edge E = edge[i];
			if(dist[E.to] > dist[u] + E.val)
			{
				dist[E.to] = dist[u] + E.val;
				if(!vis[E.to])
				{
					vis[E.to] = true;
					S[top++] = E.to;
				}
			}
		}
	}
	printf("%d\n", dist[n]);
} 
int main()
{
	while(scanf("%d%d", &n, &m) != EOF)
	{
		init();
		getMap();
		SPFA();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值