poj 2752 Seek the Name, Seek the Fame 【在原串中 找所有既是原串前缀又是原串后缀的子串长度】

Seek the Name, Seek the Fame
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14150 Accepted: 7046

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18

1 2 3 4 5

题意:给你一个字符串,让你求出 所有既是该串前缀又是该串后缀的子串长度。并按升序输出长度。

如下:

a b a b c a b a b a b a b c a b a b
对应f[]数组
0 0 1 2 0 1 2 3 4 3 4 3 4 5 6 7 8 9 
由f[9] - > f[f[9]] - > f[f[f[9]]] -> f[] = 0 终止 过程中的f[]值全是合法解。

思路:由失配数组f[],从字符串长度len 将f[len] 向前递推到 f[i]为0,在这个过程中所有非0的f[]值均是满足题意的子串长度。


#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 400000+100
using namespace std;
int f[MAXN];
char P[MAXN];
int rec[MAXN];
int len;
void getfail()
{
	f[0] = f[1] = 0;
	for(int i = 1; i < len; i++)
	{
		int j = f[i];
		while(j && P[i] != P[j])
			j = f[j];
		f[i+1] = P[i] == P[j] ? j + 1 : 0;
	}
}
int main()
{
	while(scanf("%s", P) != EOF)
	{
		len = strlen(P);
		getfail();
		int k = 0;
		for(int i = len; f[i]; i = f[i])
			rec[k++] = f[i];
		for(int i = k-1; i >= 0; i--)
			printf("%d ", rec[i]);
		printf("%d\n", len);
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值