poj 2096 Collecting Bugs 【概率DP】【逆向递推求期望】

Collecting Bugs
Time Limit: 10000MS Memory Limit: 64000K
Total Submissions: 3523 Accepted: 1740
Case Time Limit: 2000MS Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000


题意:一个软件有S个系统,但会产生N种bug。一个人一天可以发现一个bug,这个bug既属于某一个系统,又属于某一个分类。每个bug属于某个系统的概率是1/S,属于某种分类的概率是1/N。现在问你发现N种bug且S个系统都发现bug的天数的期望。



思路:用dp[i][j]表示发现i种bug且j个系统都发现bug的天数的期望。可以得到4种状态


1,dp[i][j]—— 新bug  既属于已发现bug的种类,又属于已经发现bug的系统。则有概率 (i / S) * (j / N)

2,dp[i+1][j]—— 新bug  不属于已发现bug的种类,属于已经发现bug的系统。则有概率 (1 - i / N) * (j / S)

3,dp[i][j+1]—— 新bug  属于已发现bug的种类,不属于已经发现bug的系统。则有概率 (i / N) * (1 - j / S)

4,dp[i+1][j+1]—— 新bug 既不属于已经发现bug的种类,也不属于已经发现bug的系统。则有概率 (1 - i / N) * (1 - j / S)


求期望倒着递推,由dp[N][S] = 0 退出 dp[0][0]即可。注意推导时 全是浮点型。



AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
double dp[1010][1010];
int main()
{
    int N, S;
    while(scanf("%d%d", &N, &S) != EOF)
    {
        memset(dp, 0, sizeof(dp));
        for(int i = N; i >= 0; i--)
        {
            for(int j = S; j >= 0; j--)
            {
                if(i == N && j == S) continue;
                double x = i, y = j;
                double p1 = dp[i+1][j] * (y / S) * (1 - x / N);
                double p2 = dp[i][j+1] * (x / N) * (1 - y / S);
                double p3 = dp[i+1][j+1] * (1 - y / S) * (1 - x / N);
                double p0 = 1 - (x / N) * (y / S);
                dp[i][j] = (p1 + p2 + p3 + 1) / p0;
            }
        }
        printf("%.4lf\n", dp[0][0]);
    }
    return 0;
}



1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值