hdoj 2222 Keywords Search 【AC自动机 入门题】 【求目标串中出现了几个模式串】

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 44687    Accepted Submission(s): 14103


Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 

Output
Print how many keywords are contained in the description.
 

Sample Input
  
  
1 5 she he say shr her yasherhs
 

Sample Output
  
  
3
 

AC自动机入门题目。

幸好昨天看了KMP,今天又写了字典树的总结。

在此 ORZ  bin神!!!


AC代码:


#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
#define MAXN 500000+10
using namespace std;
char str[1000000+10];
struct Trie
{
    int next[MAXN][30], fail[MAXN], word[MAXN];
    int root, L;
    int newnode()//新建节点
    {
        for(int i = 0; i < 26; i++)
            next[L][i] = -1;//初始化-1
        word[L++] = 0;
        return L-1;
    }
    void init()//初始化节点
    {
        L = 0;
        root = newnode();
    }
    //插入字符串 同字典树 比较好理解
    void Insert(char *buf)
    {
        int len = strlen(buf);
        int now = root;
        for(int i = 0; i < len; i++)
        {
            if(next[now][buf[i]-'a'] == -1)
                next[now][buf[i]-'a'] = newnode();//新建
            now = next[now][buf[i]-'a'];
        }
        word[now]++;//数目加一
    }
    //构造失败指针
    void Build()
    {
        queue<int> Q;
        fail[root] = root;
        for(int i = 0; i < 26; i++)
        {
            if(next[root][i] == -1)
                next[root][i] = root;//指向root
            else
            {
                fail[next[root][i]] = root;
                Q.push(next[root][i]);
            }
        }
        while(!Q.empty())
        {
            int now = Q.front();
            Q.pop();
            for(int i = 0; i < 26; i++)
            {
                if(next[now][i] == -1)
                    next[now][i] = next[fail[now]][i];
                else
                {
                    fail[next[now][i]]=next[fail[now]][i];
                    Q.push(next[now][i]);
                }
            }
        }
    }
    //查询 类似KMP
    int Query(char *buf)
    {
        int len = strlen(buf);
        int now = root;
        int ans = 0;//查询结果
        for(int i = 0; i < len; i++)
        {
            now = next[now][buf[i]-'a'];
            int temp = now;//记录now  从当前开始匹配
            while(temp != root)//直到指向root 为止
            {
                ans += word[temp];
                word[temp] = 0;
                temp = fail[temp];
            }
        }
        return ans;
    }
};
Trie ac;
int main()
{
    int t, N;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &N);
        ac.init();
        for(int i = 0; i < N; i++)
        {
            scanf("%s", str);
            ac.Insert(str);
        }
        ac.Build();
        scanf("%s", str);
        printf("%d\n", ac.Query(str));
    }
    return 0;
}



  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值