poj 1745 Divisibility 【DP】

Divisibility
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11044 Accepted: 3949

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible




题意:给你N个数和一个数K,问你能不能 按顺序在两个数间添加一个运算符使得N个数的结果mod K = 0。(运算符只能是加减)



思路:设dp[i][j]表示前i个数经过加减后 结果mod K = j是成立的,那么我们只要推出dp[N][0]是否为1就ok了。


状态转移方程

当dp[i-1][j]非0时

1,dp[i][t] = 1其中t = ((j + a[i]) % K + K) % K. 说明一下——(j + a[i])%K后 加个K最后再取余 是为了避免值是负数。

2,dp[i][t] = 1其中t = ((j - a[i]) % K + K) % K.


AC代码:


#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 10000+10
using namespace std;
int dp[MAXN][110];//表示前i个数经过加减运算后 结果mod K = j 是成立的
int a[MAXN];
int main()
{
    int N, K;
    while(scanf("%d%d", &N, &K) != EOF)
    {
        for(int i = 1; i <= N; i++)
            scanf("%d", &a[i]);
        memset(dp, 0, sizeof(dp));//初始化
        dp[0][0] = 1;//初值
        for(int i = 1; i <= N; i++)
        {
            for(int j = 0; j < K; j++)
            {
                if(dp[i-1][j])
                {
                    //注意j+a[i] 或者 j-a[i]可能是负数 需要加K处理
                    int t = ((j + a[i]) % K + K) % K;
                    dp[i][t] = 1;
                    t = ((j - a[i]) % K + K) % K;
                    dp[i][t] = 1;
                }
            }
        }
        if(dp[N][0])
            printf("Divisible\n");
        else
            printf("Not divisible\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值