poj 1287 Networking 【MST】【练模板】

Networking
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7410 Accepted: 4035

Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area. 
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line. 
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i. 

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0

Sample Output

0
17
16

26

最小生成树裸题,今天整理模板。写了一发kruskal和一发prime。

AC代码:

kruskal

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 55
#define MAXM 3000
#define INF 0x3f3f3f3f
using namespace std;
struct Edge
{
    int from, to, val;
};
Edge edge[MAXM];
int pre[MAXN];
int N, M;
bool cmp(Edge a, Edge b)
{
    return a.val < b.val;
}
void init()
{
    for(int i = 1; i <= N; i++)
        pre[i] = i;
}
void getMap()
{
    int a, b, c;
    for(int i = 0; i < M; i++)
    {
        scanf("%d%d%d", &a, &b, &c);
        edge[i].from = a;
        edge[i].to = b;
        edge[i].val = c;
    }
}
int find(int p)
{
    int t;
    int child = p;
    while(p != pre[p])
        p = pre[p];
    while(child != p)
    {
        t = pre[child];
        pre[child] = p;
        child = t;
    }
    return p;
}
void merge(int x, int y)
{
    int fx = find(x);
    int fy = find(y);
    if(fx != fy)
        pre[fx] = fy;
}
void solve()
{
    sort(edge, edge+M, cmp);
    int ans = 0;
    for(int i = 0; i < M; i++)
    {
        if(find(edge[i].from) != find(edge[i].to))
            ans += edge[i].val, merge(edge[i].from, edge[i].to);
    }
    printf("%d\n", ans);
}
int main()
{
    while(scanf("%d", &N), N)
    {
        scanf("%d", &M);
        init();
        getMap();
        solve();
    }
    return 0;
}


prime:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 60
#define INF 0x3f3f3f3f
using namespace std;
int Map[MAXN][MAXN];
int N, M;
void init()
{
    for(int i = 1; i <= N; i++)
    {
        Map[i][i] = 0;
        for(int j = i+1; j <= N; j++)
            Map[i][j] = Map[j][i] = INF;
    }
}
void getMap()
{
    int a, b, c;
    for(int i = 0; i < M; i++)
    {
        scanf("%d%d%d", &a, &b, &c);
        if(Map[a][b] > c)
            Map[a][b] = Map[b][a] = c;
    }
}
int dist[MAXN], low[MAXN];
bool vis[MAXN];
void prime()
{
    int ans = 0;
    int next, Min;
    for(int i = 1; i <= N; i++)
    {
        low[i] = Map[1][i];
        vis[i] = false;
    }
    vis[1] = true;
    for(int i = 2; i <= N; i++)
    {
        next = 1; Min = INF;
        for(int j = 1; j <= N; j++)
        {
            if(!vis[j] && Min > low[j])
            {
                Min = low[j];
                next= j;
            }
        }
        vis[next] = true;
        ans += Min;
        //if(Min == INF) //最小生成树不存在
        for(int j = 1; j <= N; j++)
        {
            if(!vis[j] && low[j] > Map[next][j])
                low[j] = Map[next][j];
        }
    }
    printf("%d\n", ans);
}
int main()
{
    while(scanf("%d", &N), N)
    {
        scanf("%d", &M);
        init();
        getMap();
        prime();
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值