hdoj 4009 Transfer water 【求无根树最小树形图】



Transfer water

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 4402    Accepted Submission(s): 1564


Problem Description
XiaoA lives in a village. Last year flood rained the village. So they decide to move the whole village to the mountain nearby this year. There is no spring in the mountain, so each household could only dig a well or build a water line from other household. If the household decide to dig a well, the money for the well is the height of their house multiplies X dollar per meter. If the household decide to build a water line from other household, and if the height of which supply water is not lower than the one which get water, the money of one water line is the Manhattan distance of the two households multiplies Y dollar per meter. Or if the height of which supply water is lower than the one which get water, a water pump is needed except the water line. Z dollar should be paid for one water pump. In addition,therelation of the households must be considered. Some households may do not allow some other households build a water line from there house. Now given the 3‐dimensional position (a, b, c) of every household the c of which means height, can you calculate the minimal money the whole village need so that every household has water, or tell the leader if it can’t be done.
 

Input
Multiple cases. 
First line of each case contains 4 integers n (1<=n<=1000), the number of the households, X (1<=X<=1000), Y (1<=Y<=1000), Z (1<=Z<=1000). 
Each of the next n lines contains 3 integers a, b, c means the position of the i‐th households, none of them will exceeded 1000. 
Then next n lines describe the relation between the households. The n+i+1‐th line describes the relation of the i‐th household. The line will begin with an integer k, and the next k integers are the household numbers that can build a water line from the i‐th household. 
If n=X=Y=Z=0, the input ends, and no output for that. 
 

Output
One integer in one line for each case, the minimal money the whole village need so that every household has water. If the plan does not exist, print “poor XiaoA” in one line. 
 

Sample Input
      
      
2 10 20 30 1 3 2 2 4 1 1 2 2 1 2 0 0 0 0
 

Sample Output
      
      
30
Hint
In 3‐dimensional space Manhattan distance of point A (x1, y1, z1) and B(x2, y2, z2) is |x2‐x1|+|y2‐y1|+|z2‐z1|.
 



题意:一个村庄有N个家庭,他们都需要用水,已经给出每个家庭房子的坐标和高度。他们可以选择自己建水源(费用为房子高度乘以X),或者从有水源的村庄引一条渠道(费用为两者房子的曼哈顿距离乘以Y,若供应水源的家庭的房子高度低于得到水的家庭的房子高度,那么每修建一条水渠还需要额外的Z费用)。现在给你所有家庭自建水源后,可能引水的对象(有的家庭之间有矛盾,所以不会引水给对方)。问你需要的最少费用使得N个家庭都用上水,若不存在一种方案输出poor XiaoA。


思路:建立虚根N,连接所有家庭, 边权为他们自建水源的费用。所有家庭向他们可能引水的对象建边, 边权为引渠道的费用,然后跑一遍朱刘算法就ok了。


朱刘算法要注意自环的处理,虽然这道题不处理也能过。


AC代码:


#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <vector>
#include <algorithm>
#define MAXN 1010
#define MAXM 1000000+1010
#define INF 0x3f3f3f3f
#define LL long long
using namespace std;
struct Node
{
    int x, y, h;
};
Node num[MAXN];
struct Edge
{
    int from, to, cost;
};
Edge edge[MAXM];
int edgenum;//边数
int pre[MAXN], in[MAXN];;
int vis[MAXN], id[MAXN];
int N, X, Y, Z;
int dis(Node a, Node b)//曼哈顿距离
{
    return abs(a.x - b.x) + abs(a.y - b.y) + abs(a.h - b.h);
}
void addEdge(int u, int v, int w)
{
    Edge E = {u, v, w};
    edge[edgenum++] = E;
}
void getMap()
{
    edgenum = 0;
    for(int i = 0; i < N; i++)
        scanf("%d%d%d", &num[i].x, &num[i].y, &num[i].h),
        addEdge(N, i, num[i].h * X);//建立虚根N
    int k, y;
    for(int i = 0; i < N; i++)
    {
        scanf("%d", &k);
        while(k--)
        {
            scanf("%d", &y);
            y--;
            if(i == y) continue;//加上保险  防止自环
            int c = dis(num[i], num[y]) * Y;;
            if(num[i].h < num[y].h)
                c += Z;
            addEdge(i, y, c);
        }
    }
}
LL zhuliu(int root, int n, int m, Edge *edge)
{
    LL res = 0;
    int u, v;
    while(1)
    {
        for(int i = 0; i < n; ++i)
            in[i] = INF;
        for(int i = 0; i < m; i++)
        {
            Edge E = edge[i];
            if(E.from != E.to && E.cost < in[E.to])
            {
                pre[E.to] = E.from;
                in[E.to] = E.cost;
            }
        }
        for(int i = 0; i < n; i++)
            if(in[i] == INF && i != root)
                return -1;
        int tn = 0;
        memset(id, -1, sizeof(id));
        memset(vis, -1, sizeof(vis));
        in[root] = 0;
        for(int i = 0; i < n; i++)
        {
            res += in[i];
            v = i;
            while(vis[v] != i && id[v] == -1 && v != root)
            {
                vis[v] = i;
                v = pre[v];
            }
            while(id[v] == -1 && v != root)
            {
                for(u = pre[v]; u != v; u = pre[u])
                    id[u] = tn;
                id[v] = tn++;
            }
        }
        if(tn == 0) break;
        for(int i = 0; i < n; i++)
            if(id[i] == -1)
                id[i] = tn++;
        for(int i = 0; i < m; i++)
        {
            v = edge[i].to;
            edge[i].from = id[edge[i].from];
            edge[i].to = id[edge[i].to];
            if(edge[i].from != edge[i].to)
                edge[i].cost -= in[v];
        }
        n = tn;
        root = id[root];
    }
    return res;
}
int main()
{
    while(scanf("%d%d%d%d", &N, &X, &Y, &Z), N||X||Y||Z)
    {
        getMap();
        LL ans = zhuliu(N, N+1, edgenum, edge);
        if(ans == -1)
            printf("poor XiaoA\n");
        else
            printf("%lld\n", ans);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值