hdoj 5475 An easy problem 【线段树单点更新 + 区间乘积】



An easy problem

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 647    Accepted Submission(s): 380


Problem Description
One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.
1. multiply X with a number.
2. divide X with a number which was multiplied before.
After each operation, please output the number X modulo M.
 

Input
The first line is an integer T( 1T10 ), indicating the number of test cases.
For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. ( 1Q105,1M109 )
The next Q lines, each line starts with an integer x indicating the type of operation.
if x is 1, an integer y is given, indicating the number to multiply. ( 0<y109 )
if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It's guaranteed that in type 2 operation, there won't be two same n.
 

Output
For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.
Then Q lines follow, each line please output an answer showed by the calculator.
 

Sample Input
      
      
1 10 1000000000 1 2 2 1 1 2 1 10 2 3 2 4 1 6 1 7 1 12 2 7
 

Sample Output
      
      
Case #1: 2 1 2 20 10 1 6 42 504 84
 



比赛时逆元卡死了,最后康总线段树KO了。


题意:有Q次操作,操作分两种。

1  y  ——  表示当前结果乘以y。

2  n ——  表示当前结果除去第n步乘上的y。 


不能直接逆元,中间会出问题。。。

思路:可以用线段树维护区间的乘积来表示每次操作的结果,初始化所有区间值为1。碰到操作1更新当前位置的值为y,碰到操作2,把第n个位置的值变为1。




AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 100000+10
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
#define LL long long
using namespace std;
struct Tree
{
    int l, r;
    LL sum;
};
Tree tree[MAXN<<2];
int a[MAXN];
int Q, M;
void PushUp(int o){
    tree[o].sum = tree[ll].sum % M * tree[rr].sum % M;
}
void build(int o, int l, int r)
{
    tree[o].l = l;
    tree[o].r = r;
    tree[o].sum = 1;
    if(l == r)
        return ;
    int mid = (l + r) >> 1;
    build(lson);
    build(rson);
}
void update(int o, int pos, int val)
{
    if(tree[o].l == tree[o].r)
    {
        tree[o].sum = val%M;
        return ;
    }
    int mid = (tree[o].l + tree[o].r) >> 1;
    if(pos <= mid)
        update(ll, pos, val);
    else
        update(rr, pos, val);
    PushUp(o);
}
LL query(int o, int L, int R)
{
    if(L <= tree[o].l && R >= tree[o].r)
        return tree[o].sum % M;
    int mid = (tree[o].l + tree[o].r) >> 1;
    if(R <= mid)
        return query(ll, L, R);
    else if(L > mid)
        return query(rr, L, R);
    else
        return query(ll, L, mid) * query(rr, mid+1, R) % M;
}
int main()
{
    int t, k = 1;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &Q, &M);
        build(1, 1, Q);
        printf("Case #%d:\n", k++);
        for(int i = 1; i <= Q; i++)
        {
            int op;
            scanf("%d%d", &op, &a[i]);
            if(op == 1)
                update(1, i, a[i]);
            else if(op == 2)
                update(1, a[i], 1);
            printf("%lld\n", query(1, 1, i) % M);
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值