hdoj 5585 Numbers 【水题】



Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 53    Accepted Submission(s): 41


Problem Description
There is a number N.You should output "YES" if N is a multiple of 2, 3 or 5,otherwise output "NO".
 

Input
There are multiple test cases, no more than 1000 cases.
For each case,the line contains a integer N. (0<N<1030)
 

Output
For each test case,output the answer in a line.
 

Sample Input
      
      
2 3 5 7
 

Sample Output
      
      
YES YES YES NO
 



题意:给定一个大数,问它是否为2、3或5的倍数。




AC代码:


#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#define INF 0x3f3f3f
#define eps 1e-8
#define MAXN (5000+10)
#define MAXM (100000)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%.2lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
using namespace std;
int main()
{
    char str[40];
    while(scanf("%s", str) != EOF)
    {
        int len = strlen(str);
        int num;
        if(len == 1)
        {
            num = str[0] - '0';
            if(num % 3 == 0 || num % 2 == 0 || num % 5 == 0)
                printf("YES\n");
            else
                printf("NO\n");
            continue;
        }
        bool flag = false;
        if(str[len-1] == '2' || str[len-1] == '0' || str[len-1] == '5' || str[len-1] == '4' || str[len-1] == '6' || str[len-1] == '8')
            flag = true;
        num = 0;
        for(int i = 0; i < len; i++)
            num += str[i] - '0';
        if(num % 3 == 0)
            flag = true;
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值