hdoj 5597 GTW likes function 【打表找规律】

GTW likes function

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 243    Accepted Submission(s): 134


Problem Description
Now you are given two definitions as follows.

f(x)=xk=0(1)k22x2kCk2xk+1,f0(x)=f(x),fn(x)=f(fn1(x))(n1)

Note that  φ(n)  means Euler’s totient function.( φ(n) is an arithmetic function that counts the positive integers less than or equal to n that are relatively prime to n.)

For each test case, GTW has two positive integers —  n  and  x , and he wants to know the value of the function  φ(fn(x)) .
 

Input
There is more than one case in the input file. The number of test cases is no more than 100. Process to the end of the file.

Each line of the input file indicates a test case, containing two integers,  n  and  x , whose meanings are given above.  (1n,x1012)
 

Output
In each line of the output file, there should be exactly one number, indicating the value of the function  φ(fn(x))  of the test case respectively.
 

Sample Input
  
  
1 1 2 1 3 2
 

Sample Output
  
  
2 2 2
 




问题描述
现在给出下列两个定义:
	f(x)=f_{0}(x)=\sum_{k=0}^{x}(-1)^{k}2^{2x-2k}C_{2x-k+1}^{k},f_{n}(x)=f(f_{n-1}(x))(n\geq 1)f(x)=f0(x)=k=0x(1)k22x2kC2xk+1k,fn(x)=f(fn1(x))(n1)

	\varphi(n)φ(n)为欧拉函数。指的是不超过nn的与nn互质的正整数个数。

对于每组数据,GTW有两个正整数n,xn,x,现在他想知道函数\varphi(f_{n}(x))φ(fn(x))的值。
输入描述
输入有多组数据,不超过100组。每数据输入一行包含2个整数组nnxx(1\leq n,x \leq 10^{12})(1n,x1012)
输出描述
对于每组数据输出一行,表示函数\varphi(f_{n}(x))φ(fn(x))的值。


打表代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <vector>
#define INF 0x3f3f3f3f
#define eps 1e-8
#define MAXN (50000+1)
#define MAXM (5000000000)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%.2lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
using namespace std;
LL C[110][110];
void getC()
{
    for(int i = 0; i <= 50; i++)
        C[i][0] = 1, C[i][i] = 1;
    for(int i = 1; i <= 50; i++)
        for(int j = 1; j < i; j++)
            C[i][j] = C[i-1][j-1] + C[i-1][j];
}
LL Pow(LL a, LL n)
{
    LL ans = 1;
    while(n)
    {
        ans *= a;
        n--;
    }
    return ans;
}
LL f(LL x)
{
    LL ans = 0;
    for(LL k = 0; k <= x; k++)
    {
        if(k & 1LL)
            ans -= Pow(2, 2*x-2*k) * C[2*x-k+1][k];
        else
            ans += Pow(2, 2*x-2*k) * C[2*x-k+1][k];
    }
    return ans;
}
int main()
{
    getC();
    for(LL i = 1; i <= 20LL; i++)
        Pl(f(i));
    return 0;
}

规律明显为f(x) = x + 1,这样f n(x) = x + n + 1。下面就是求解欧拉函数了。

AC代码:数据很大,先除后乘。

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <vector>
#define INF 0x3f3f3f3f
#define eps 1e-8
#define MAXN (50000+1)
#define MAXM (5000000000)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%.2lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
using namespace std;
LL euler(LL n)
{
    LL ans = n;
    for(LL i = 2; i * i <= n; i++)
    {
        if(n % i == 0)
        {
            ans = ans / i * (i-1);
            while(n % i == 0)
                n /= i;
        }
    }
    if(n > 1) ans = ans / n * (n-1);
    return ans;
}
int main()
{
    LL n, x;
    while(scanf("%lld%lld", &n, &x) != EOF){
        printf("%I64d\n", euler(n+x+1));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值