hdoj 3333 Turing Tree 【树状数组】

题目链接:hdoj 3333 Turing Tree

Turing Tree

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4408 Accepted Submission(s): 1533

Problem Description
After inventing Turing Tree, 3xian always felt boring when solving problems about intervals, because Turing Tree could easily have the solution. As well, wily 3xian made lots of new problems about intervals. So, today, this sick thing happens again…

Now given a sequence of N numbers A1, A2, …, AN and a number of Queries(i, j) (1≤i≤j≤N). For each Query(i, j), you are to caculate the sum of distinct values in the subsequence Ai, Ai+1, …, Aj.

Input
The first line is an integer T (1 ≤ T ≤ 10), indecating the number of testcases below.
For each case, the input format will be like this:
* Line 1: N (1 ≤ N ≤ 30,000).
* Line 2: N integers A1, A2, …, AN (0 ≤ Ai ≤ 1,000,000,000).
* Line 3: Q (1 ≤ Q ≤ 100,000), the number of Queries.
* Next Q lines: each line contains 2 integers i, j representing a Query (1 ≤ i ≤ j ≤ N).

Output
For each Query, print the sum of distinct values of the specified subsequence in one line.

Sample Input
2
3
1 1 4
2
1 2
2 3
5
1 1 2 1 3
3
1 5
2 4
3 5

Sample Output
1
5
6
3
6

题意:问你区间不同元素之和。

思路:在线想了好久,优化不了。离线做。
将区间排序,这样对于所有的查询区间可以做到O(n)的遍历。每次只需统计第一次出现的数字,将其在对应位置插入树状数组,当该数已经出现后就从树状数组里面删除,修改标记,在新的位置插入。每次遍历到R的时候,R前面的信息以及统计好了,这样每次只需统计区间和的即可。时间复杂度O(nlogn)。

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <vector>
#include <cstring>
#include <queue>
#include <map>
#include <set>
#define CLR(a, b) memset(a, (b), sizeof(a))
using namespace std;
typedef long long LL;
const int MAXN = 3 * 1e4 + 10;
const int MAXM = 1e5 + 10;
const int INF = 1e9 + 10;
struct Node {
    int l, r, id;
};
Node num[MAXM];
bool cmp(Node a, Node b) {
    return a.r < b.r;
}
LL C[MAXN];
int a[MAXN];
map<int, int> lp;
int lowbit(int x) {
    return x & (-x);
}
int n;
void add(int x, int d) {
    while(x <= n) {
        C[x] += d;
        x += lowbit(x);
    }
}
LL Sum(int x) {
    LL s = 0;
    while(x > 0) {
        s += C[x];
        x -= lowbit(x);
    }
    return s;
}
LL ans[MAXM];
int main()
{
    int t; scanf("%d", &t);
    while(t--) {
        scanf("%d", &n); lp.clear();
        for(int i = 1; i <= n; i++) {
            scanf("%d", &a[i]);
        }
        int m; scanf("%d", &m);
        for(int i = 1; i <= m; i++) {
            scanf("%d%d", &num[i].l, &num[i].r);
            num[i].id = i;
        }
        sort(num+1, num+m+1, cmp);
        CLR(C, 0); int j = 1;
        for(int i = 1; i <= m; i++) {
            while(j <= num[i].r) {
                if(!lp[a[j]]) {
                    add(j, a[j]);
                }
                else {
                    add(lp[a[j]], -a[j]);
                    add(j, a[j]);
                }
                lp[a[j]] = j; j++;
            }
            ans[num[i].id] = Sum(num[i].r) - Sum(num[i].l-1);
        }
        for(int i = 1; i <= m; i++) {
            printf("%lld\n", ans[i]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值