PAT (Advanced Level) Practice 1063 Set Similarity (25分)——测试点4

记做题时犯的错
题目地址:https://pintia.cn/problem-sets/994805342720868352/problems/994805409175420928

题目描述

Given two sets of integers, the similarity of the sets is defined to be Nc / N​t​​ ×100%, where N​c is the number of distinct common numbers shared by the two sets, and N​t is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

输入格式

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10^​4) and followed by M integers in the range [0,10^​9]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.
​​ .

输出格式

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

输入样例1

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

输出样例

50.0%
33.3%

解题思路

题意:
给出N个集合,M个查询,每个查询给两个集合的编号a和b,求a和b交集和并集的元素个数的比率。

做法:

  1. 将每个集合放入set中,消除每个集合中相同的数
  2. 使用same记录a和b交集的元素个数,total记录a和b并集的元素个数
  3. total等于b集合的元素个数
  4. 对a进行遍历,将a的每个数和b进行比较
    若b中有相同数,same++
    若b中没有相同的数,则说明找到一个不同的数,total++
  5. 输出same和total的比率

出错点

  1. 刚开始使用的是用新的集合temp来存储a和b的并集,total = temp中元素的个数,same = a和b的元素的总个数 - total。但测试点4超时了,是4中的集合元素个数较多,加入新的集合时花费时间过长

代码

#include <iostream>
#include <string.h>
#include <algorithm>
#include <set>

using namespace std; 

set<int> Set[51];

int main() {
	int N;  //集合的总数 
	scanf("%d",&N);
	for(int i = 1;i <= N;i ++){
		int M;    //每个集合中数字的个数 
		scanf("%d",&M);
		for(int j = 0;j < M;j ++){
			int v;
			scanf("%d",&v);
			Set[i].insert(v); 
		}
	}
	
	int K;
	scanf("%d",&K);
	for(int i = 0;i < K;i ++){
		int st1,st2;
		scanf("%d %d",&st1,&st2);
		int total,same = 0;
		total = Set[st2].size();
		for(set<int>::iterator it = Set[st1].begin(); it != Set[st1].end(); it++) {
			if(Set[st2].find(* it) != Set[st2].end())
			    same ++;
			else
			    total ++;
		}
		printf("%.1f%\n",same * 100.0 / total);
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值