HDU_1232畅通工程:
Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
Sample Input
4 21 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0
Sample Output
1
0
2
998
题目大意:有N个城镇,M条道路,问你再添加多少条道路可使所有城镇两两可达= =
分析:这是典型的并查集,求出共有多少组城镇,将这些块连接起来即可。
参考代码:
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<stack>
#include<queue>
#include<map>
#include<vector>
#include<iostream>
using namespace std;
const int maxn = 1000+10;
int n,m;
int pre[maxn];
int tmp[maxn];
int Find( int x)
{
if( x == pre[x])
return x;
return pre[x] = Find(pre[x]);
}
void Union( int x, int y)
{
int px = Find(x);
int py = Find(y);
if( px == py)
return;
pre[px] = py;
}
int main()
{
while( ~scanf("%d",&n) && n)
{
scanf("%d",&m);
for( int i = 1; i <= n; i++)
pre[i] = i;
int a,b;
for( int i = 1; i <=m; i++)
{
scanf("%d%d",&a,&b);
Union(a,b);
}
for( int i = 1; i <= n; i++)
tmp[i] = Find(i);
sort(tmp+1,tmp+1+n);
int t = tmp[1];
int ans = 0;
for( int i = 2; i <= n; i++)
{
if( tmp[i] != t)
{
ans++;
t = tmp[i];
}
}
printf("%d\n",ans);
}
return 0;
}
HDU_1233还是畅通工程
Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最小的公路总长度。
Sample Input
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
Sample Output
35
题目大意:有N个城镇,给出每两个城镇之间的距离,求得使每个城镇之间都可达的最小公路长度= =
分析:本题为最小生成树问题,可以在并查集的基础上求解。首先按照路径长度由小到大排序,然后如果两点不在一个组里面,合并,直至合并到有n-1条边。
参考代码:
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<stack>
#include<queue>
#include<map>
#include<vector>
#include<iostream>
using namespace std;
const int maxn = 100+10;
int n;
struct connect{
int u;
int v;
int w;
};
connect con[maxn*(maxn-1)/2];
int pre[maxn];
bool cmp( connect a, connect b)
{
if( a.w != b.w)
return a.w < b.w;
}
int Find( int x)
{
if( x == pre[x])
return x;
return pre[x] = Find(pre[x]);
}
bool Union( int x, int y)
{
int px = Find(x);
int py = Find(y);
if( px != py)
{
pre[px] = py;
return true;
}
return false;
}
int main()
{
while( ~scanf("%d",&n) && n)
{
int a,b,c;
int m = (n*(n-1))/2;
for( int i = 1; i <= n; i++)
pre[i] = i;
for( int i = 1; i <= m; i++)
scanf("%d%d%d",&con[i].u,&con[i].v,&con[i].w);
sort( con+1, con+1+m, cmp);
int cnt = 0;
int sum = 0;
for( int i = 1; i <= m; i++)
{
if( Union( con[i].u, con[i].v))
{
cnt++;
sum += con[i].w;
}
if( cnt == n-1)
break;
}
printf("%d\n",sum);
}
return 0;
}