codevs1242布局【USACO】

题目描述 Description
当排队等候喂食时,奶牛喜欢和它们的朋友站得靠近些。FJ有N(2<=N<=1000)头奶牛,编号从1到N,沿一条直线站着等候喂食。奶牛排在队伍中的顺序和它们的编号是相同的。因为奶牛相当苗条,所以可能有两头或者更多奶牛站在同一位置上。即使说,如果我们想象奶牛是站在一条数轴上的话,允许有两头或更多奶牛拥有相同的横坐标。

一些奶牛相互间存有好感,它们希望两者之间的距离不超过一个给定的数L。另一方面,一些奶牛相互间非常反感,它们希望两者间的距离不小于一个给定的数D。给出ML条关于两头奶牛间有好感的描述,再给出MD条关于两头奶牛间存有反感的描述。(1<=ML,MD<=10000,1<=L,D<=1000000)

你的工作是:如果不存在满足要求的方案,输出-1;如果1号奶牛和N号

奶牛间的距离可以任意大,输出-2;否则,计算出在满足所有要求的情况下,1号奶牛和N号奶牛间可能的最大距离。

输入描述 Input Description
Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
输出描述 Output Description
Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
样例输入 Sample Input
4 2 1
1 3 10
2 4 20
2 3 3

样例输出 Sample Output
27

这个题目用差分约束做,建单向边,把有好感的限定距离设为正权,反感的反向建边,设负权,跑最短路,因为我们这样建边的时候就能保证是最大距离了,只要跑一边最短路就行,然后判环,判断有没有一条这样的路径。
设a,b之间的距离不能超过c,则可以写出式子:b-a+1<=c
b < a+c 这个式子很眼熟,很像最短路里面的松弛操作,dis[v] > dis[x]+e.cost;
所以就可以建a->b权值为c的边,大于等于的情况也是同样的道理。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <queue>
#define inf 2147483647
using namespace std;
const int MAXN = 1000000+10;
int head[MAXN],nxt[MAXN<<1],tim[MAXN],dis[MAXN],tot,n,ml,md;
bool vis[MAXN],flag = 0;
struct Edge
{
    int from,to,cost;
}edge[MAXN<<1];
void build(int f,int t,int d)
{
    edge[++tot] = (Edge){f,t,d};
    nxt[tot] = head[f];
    head[f] = tot;
}
queue <int>q;
void spfa(int s)
{
    memset(dis,0x3f,sizeof(dis));
    dis[s] = 0;
    vis[s] = 1;
    q.push(s);
    while(!q.empty())
    {
        int x = q.front();
        q.pop();
        vis[x] = 0;
        for(int i = head[x] ; i ; i = nxt[i])
        {
            Edge e = edge[i];
            if(++tim[e.to] > n)
            {
                flag = 1;
                break;
            }
            if(dis[e.to] > dis[x]+e.cost )
            {
                dis[e.to] = dis[x]+e.cost;

                if(!vis[e.to])
                {
                    vis[e.to] = 1;
                    q.push(e.to);
                }
            }
        }
    }
}
int main()
{
    scanf("%d%d%d",&n,&ml,&md);
    for(int i = 1; i <= ml; i ++)
    {
        int aa,bb,cc;
        scanf("%d%d%d",&aa,&bb,&cc);
        build(aa,bb,cc);
    }
    for(int i = 1; i <= md; i ++)
    {
        int aa,bb,cc;
        scanf("%d%d%d",&aa,&bb,&cc);
        build(bb,aa,-cc);
    }
    spfa(1);
    if(dis[n] >= 1061109567)
    puts("-2");
    else if(flag)
    {
        puts("-1");
    }
    else
    printf("%d",dis[n]);
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值