UVa 10098 - Generating Fast STL 排序+排列

Problem C 
Generating Fast, Sorted Permutation

Input: Standard Input

Output: Standard Output

 

Generating permutation has always been an important problem in computer science. In this problem you will have to generate the permutation of a given string in ascending order.  Remember that your algorithm must be efficient.


Input

The first line of the input contains an integer n, which indicates how many strings to follow. The next n lines contain n strings. Strings will only contain alpha numerals and never contain any space. The maximum length of the string is 10.

 
Output

For each input string print all the permutations possible in ascending order. Not that the strings should be treated, as case sensitive strings and no permutation should be repeated. A blank line should follow each output set.

 

Sample Input

3
ab
abc
bca

 

Sample Output

ab
ba

abc
acb
bac
bca
cab
cba

abc
acb
bac
bca
cab
cba


Shahriar Manzoor


题意:一个10个字符以内的字符串,要求先升序后,再全排列


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int MAX = 10+5;

char data[MAX];

int cmp(const void *a, const void *b)
{
	char *_a = (char *)a;
	char *_b=(char *)b;
	return *_a-*_b;
}

int main()
{
//	freopen("in.txt","r",stdin);
	int n;
	cin >> n;
	while(n--)
	{
		cin>>data;
		qsort(data, strlen(data), sizeof(data[0]), cmp);
		do{
			cout << data << endl;
		}while(next_permutation(data, data+strlen(data)));
		cout << endl;
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值