UVa 216 - Getting in Line 递归回溯

Getting in Line 

Computer networking requires that the computers in the network be linked.

This problem considers a ``linear" network in which the computers are chained together so that each is connected to exactly two others except for the two computers on the ends of the chain which are connected to only one other computer. A picture is shown below. Here the computers are the black dots and their locations in the network are identified by planar coordinates (relative to a coordinate system not shown in the picture).

Distances between linked computers in the network are shown in feet.

For various reasons it is desirable to minimize the length of cable used.

Your problem is to determine how the computers should be connected into such a chain to minimize the total amount of cable needed. In the installation being constructed, the cabling will run beneath the floor, so the amount of cable used to join 2 adjacent computers on the network will be equal to the distance between the computers plus 16 additional feet of cable to connect from the floor to the computers and provide some slack for ease of installation.

The picture below shows the optimal way of connecting the computers shown above, and the total length of cable required for this configuration is (4+16)+ (5+16) + (5.83+16) + (11.18+16) = 90.01 feet.

Input

The input file will consist of a series of data sets. Each data set will begin with a line consisting of a single number indicating the number of computers in a network. Each network has at least 2 and at most 8 computers. A value of 0 for the number of computers indicates the end of input.

After the initial line in a data set specifying the number of computers in a network, each additional line in the data set will give the coordinates of a computer in the network. These coordinates will be integers in the range 0 to 150. No two computers are at identical locations and each computer will be listed once.

Output

The output for each network should include a line which tells the number of the network (as determined by its position in the input data), and one line for each length of cable to be cut to connect each adjacent pair of computers in the network. The final line should be a sentence indicating the total amount of cable used.

In listing the lengths of cable to be cut, traverse the network from one end to the other. (It makes no difference at which end you start.) Use a format similar to the one shown in the sample output, with a line of asterisks separating output for different networks and with distances in feet printed to 2 decimal places.

Sample Input

6
5 19
55 28
38 101
28 62
111 84
43 116
5
11 27
84 99
142 81
88 30
95 38
3
132 73
49 86
72 111
0

Sample Output

**********************************************************
Network #1
Cable requirement to connect (5,19) to (55,28) is 66.80 feet.
Cable requirement to connect (55,28) to (28,62) is 59.42 feet.
Cable requirement to connect (28,62) to (38,101) is 56.26 feet.
Cable requirement to connect (38,101) to (43,116) is 31.81 feet.
Cable requirement to connect (43,116) to (111,84) is 91.15 feet.
Number of feet of cable required is 305.45.
**********************************************************
Network #2
Cable requirement to connect (11,27) to (88,30) is 93.06 feet.
Cable requirement to connect (88,30) to (95,38) is 26.63 feet.
Cable requirement to connect (95,38) to (84,99) is 77.98 feet.
Cable requirement to connect (84,99) to (142,81) is 76.73 feet.
Number of feet of cable required is 274.40.
**********************************************************
Network #3
Cable requirement to connect (132,73) to (72,111) is 87.02 feet.
Cable requirement to connect (72,111) to (49,86) is 49.97 feet.
Number of feet of cable required is 136.99.
 
 
译文:

電腦網路是把電腦用網路線連接起來。在這個問題中,我們考慮的是一種線性(liner)的網路架構。在此架構中,電腦被連成一串。也就是除了兩端的電腦各只連接一部電腦之外,其餘的電腦都正好連接2部電腦,請看以下的圖。在這裡,黑點代表電腦,且他們的位置以平面座標來表示。2部電腦間的距離以呎為單位。

現在我們需要使連接的網路線最短,這也就是你的任務。在架設網路線時,網路線在地板下,所以相連的2部電腦所需的網路線的長度為這2部電腦的距離再加上額外的16呎(用來從地板下拉到電腦以及多留一些長度讓安裝方便)。以下的圖顯示了上圖電腦最佳的佈線方式。其總長度為:(4+16)+ (5+16) + (5.83+16) + (11.18+16) = 90.01呎。

Input

輸入含有多組測試資料。每組測試資料的第一列有一個正整數n(2 <= n <= 8),代表網路中電腦的數目。接下來的n列每列有2個介於0~150之間的整數,代表一部電腦的平面座標。沒有2部電腦會在同一位置。

若n=0代表輸入結束,請參考Sample Input。

Output

每組測試資料以輸出一列*開始,然後列出布置網路線的長度,從一端到另一端(從哪一端開始都可以)。最後再列出所需的總長度。各距離均輸出到小數點後2位。請參考Sample Output的輸出格式。

 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

const int MAX=8+5;

// 记录电脑的坐标 
struct Node{
	int x, y;
};

Node node[MAX];
float dis[MAX][MAX];
int vis[MAX];
int  num[MAX], resu[MAX];
int n, nCase=1;
float ans=100000.0;

void init()
{
	memset(dis, 0 , sizeof(dis));
	memset(vis, 0, sizeof(vis));
	ans = 100000.0;
} 

void read()
{
	for(int i=1; i <= n; i++)
		cin >> node[i].x >> node[i].y;
}
// 计算出所有电脑之间的距离 
void getDis()
{
	for(int i=1; i <= n; i++)
	{
		for(int j=1; j <= n; j++)
		{
			if(j==i) continue;
			int x = node[i].x-node[j].x;
			int y = node[i].y-node[j].y;
			dis[i][j] = sqrt(x*x+y*y)+16;		
		}
	}
}
// 深搜 求得最小的值 
void dfs(int u, int length, float sum)
{
	if(length==n)
	{
		if(sum < ans)
		{
			ans = sum;
			for(int i=1; i <= n; i++)
				resu[i] = num[i];
		}
		return ;
	}
	for(int v=1; v <= n; v++)
	{
		if(u!= v && !vis[v])
		{ 
			vis[u] = vis[v] = 1;
			num[length] = u;
			num[length+1] = v;
			dfs(v, length+1, sum+dis[u][v]);
			vis[u] = vis[v] = 0;
		}
	}
}

void solve()
{
	for(int i=1; i <= n; i++)
	{
		if(!vis[i])
			dfs(i, 1, 0.0);	
	}
}
// 其实这个输出感觉有点那个...... 
void output()
{
	cout <<"**********************************************************"<< endl;
	cout << "Network #" << nCase << endl;
	for(int i=1; i <= n-1; i++)
	{
		cout << "Cable requirement to connect ";
		cout << "(" <<node[resu[i]].x << "," <<node[resu[i]].y<<")";
		cout << " to " << "(" <<node[resu[i+1]].x << "," <<node[resu[i+1]].y<<")";
		printf(" is %.2f feet.\n", dis[resu[i]][resu[i+1]]);
	}
	cout << "Number of feet of cable required is ";
	printf("%.2lf.\n", ans);
}

int main()
{
//	freopen("in.txt","r",stdin);
	while(cin>>n)
	{
		if(n==0) break;
		init();//这里忘记初始化了WA了一次,好伤心 
		read();
		getDis();
		solve();
		output();
		nCase++;
	}
	return 0;
} 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值