PAT (Advanced Level) 1005 Spell It Right

PAT 1005 Spell It Right

题目:

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤ 10 ​ 100 10​^{100} 10100).

Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five

解题思路:

在外面声明一个string类型的hash table用来存放常量;

  • 一定要定义一个string类型的变量来存储输入的数据,long long类型的也会溢出。
  • 循环遍历输入的input的每个值,然后减去’0’之后做加和
  • 最终对应相应的hash中的值挨个替换成英文。
代码:
#include <bits/stdc++.h>
#include <stdio.h>

using namespace std;
string numberStr[] = {"zero","one","two","three","four","five","six","seven","eight","nine"};

int main(){
	string input_num;
	cin >> input_num;
	long long result = 0;
	string input_str = input_num;
	//计算各个部分的和
	int i;
	for(i=0;i<input_str.length();i++){
		result += (input_str[i]-'0');
	}
	string result_str = to_string(result); 
	for(i=0;i<result_str.length();i++){
		int current_index = result_str[i]-'0';
		if(i < (result_str.length()-1)){
			cout << numberStr[current_index] << " ";
		}else{
			cout << numberStr[current_index];
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值