POJ-1284-Primitive Roots——欧拉函数

题目描述
We say that integer x, 0 <x < p, is a primitive root modulo odd prime p if and only if the set { (x i mod p) | 1 <= i <= p-1} is equal to {1, …, p-1}. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7.
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p.
输入
Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.
输出
For each p, print a single number that gives the number of primitive roots in a single line.
样例输入
23
31
79
样例输出
10
8
24

题意
给定 x, 求 x 的原根,多组输入

题解
x 的原根为φ(φ(x)),因为保证 x 为素数,φ(x)=x-1,那么就只要求φ(x-1)就好

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int n;
int phi(int x){
    int num=x;
    for(int i=2;i*i<=x;i++)
        if(x%i==0){
            num=num/i*(i-1);
            while(x%i==0) x/=i;}
    if(x>1) num=num/x*(x-1);
    return num;}
int main(){
    while(~scanf("%d",&n))
        printf("%d\n",phi(n-1));
    return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值