Primitive Roots POJ - 1284 原根, 欧拉函数

题目链接


We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (x^i mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7.
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p.

Input

Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator. 

Output

For each p, print a single number that gives the number of primitive roots in a single line. 

Sample Input

23
31
79

Sample Output

10
8
24

题意:

给你一个奇素数, 求它原根的个数.

思路:

定义:n的原根x满足条件0<x<n,并且有集合{ (x^i mod n) | 1 <= i <=n-1 } 和集合{ 1, ..., n-1 }相等
定理:如果p有原根,则它恰有φ(φ(p))个不同的原根,p为素数,当然φ(p)=p-1,因此就有φ(p-1)个原根.

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

typedef long long LL;
const int maxn = 66666;
int euler[maxn];

void Euler(){
    for(int  i = 1; i < maxn; ++i)
        euler[i] = i;
    for(int i = 2; i < maxn; ++i){
        if(euler[i] == i){
            for(int  j = i ; j < maxn; j += i)
                euler[j] -= euler[j] / i;
        }
    }
}

int main(){
    Euler();
    ios::sync_with_stdio(false);
    int n;
    while(cin >> n){
        cout<<euler[n-1]<<endl;
    }return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值