POJ2976 - Dropping tests——分数规划

题目描述
In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be这里写图片描述
Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.
Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is 这里写图片描述. However, if you drop the third test, your cumulative average becomes这里写图片描述 .
输入
The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.
输出
For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.
样例输入
3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0
样例输出
83
100
提示
To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

题意
有 n 科考试,第 i 课有 bi 题,答对 ai 题,分数为这里写图片描述,可以有 k 门不算入分数,求分数的最大值

题解
造几个数据可知排序贪心的想法是错的
因为分数的范围是 1~100,我们可以二分答案 mid,原式移项后变成 sum=∑ai-mid*∑bi, 当 sum>=0 mid 成立,反之亦然
这题恶心就在于 ans 要四舍五入,被卡了很久

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int a[1002],b[1002],n,m;
double num[1002];
bool pd(double mid){
    double sum=0;
    for(int i=1;i<=n;i++)
        num[i]=a[i]-b[i]*mid;
    sort(num+1,num+1+n);
    for(int i=m+1;i<=n;i++) sum+=num[i];
    if(sum>=0.0)return 1;
    return 0; 
}
int main(){
    while(~scanf("%d%d",&n,&m)){
        if(!n&&!m) return 0;
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        for(int i=1;i<=n;i++) scanf("%d",&b[i]);
        double l=0.0,r=1.0;
        while(r-l>1e-7){
            double mid=(l+r)/2.0;
            if(pd(mid)) l=mid;
            else r=mid;}
        printf("%1.f\n",l*100);}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值