Sicily 1782. Knapsack

Description
John wants to carry several items with a knapsack. Each item has integral size and can not be divided into smaller parts. The knapsack also has an integral capacity. Given  n items, what’s the maximal size of items can be carried without exceeding the knapsack‘s capacity?
Input
This problem contains several test cases. The first line of the input is an integer  T, which means there’re  T test cases follow. (0 <  T ≤ 20)
Each test case contains two lines. The first line contains two integers  nm, which means that there’re  n items totally, and the capacity of the knapsack is  m. The second line contains  n positive integers, the sizes (smaller than m) of different items. (0 <  n ≤ 1000, 0 <  m≤ 10000)
Output
For each test case, output one line containing the answer desired.
Sample Input
 Copy sample input to clipboard
2
3 10
2 4 7
5 100
2 12 81 63 23
Sample Output
9
100
// Problem#: 1782
// Submission#: 3708218
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include<iostream>
#include<cstdio>
#include<cctype>
#include<iomanip>
#include<vector>
#include<cstring>
#include<string>
#include<fstream>
#include<stack>
#include<vector>
#include<algorithm>
#include<cmath>
using namespace std;
int size[1000] = {0};
int maxValue[10000] = {0}; 
int max(const int& a, const int b){
    return a>b?a:b; 
}
int main(){
    int t;   
    cin>>t;    
    while(t--){
        int n,m;                      
        cin>>n>>m;
        for(int k = 0; k < n; k++){
            cin>>size[k];
        }
        for(int i = 1; i <= n; i++){
            for(int j = m; j >= size[i-1]; j--){
                maxValue[j] = max(maxValue[j],maxValue[j-size[i-1]]+size[i-1]);    
            }
        }
        cout<<maxValue[m]<<endl;
    } 
    return 0;
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值