Sicily 11157. Crossword

11157. Crossword
 
 
Time Limit: 1sec    Memory Limit:256MB
Description
Mirko has assembled an excellent crossword puzzle and now he wants to frame it. Mirko's crossword puzzle consists of M x N letters, and the frame around it should be U characters wide on top, L characters on the left, R characters on the right and D characters on the bottom side. The frame consists of characters # (hash) and . (dot) which alternate like fields on a chessboard. These characters should be arranged in a way that, if the frame is expanded to cover the entire crossword puzzle and we treat these characters as a chessboard, the # characters should be placed as the red fields on a chessboard (i.e. the top left field). See the examples below for a better understanding of the task.
Input
The first line of input contains two integers M and N (1 ≤ M, N ≤ 10). The second line of input contains integers U, L, R, D (0 ≤ U, L, R, D ≤ 5). The following M lines of input contains N characters – lowercase letters of the English alphabet. These lines represent Mirko's crossword puzzle.
Output
Output the framed crossword puzzle as stated in the text.
Sample Input
 Copy sample input to clipboard
样例1:
4 4
2 2 2 2
honi
oker
nera
irak
样例2:
2 4
1 0 3 1
rima
mama
Sample Output
样例1:
#.#.#.#.
.#.#.#.#
#.honi#.
.#oker.#
#.nera#.
.#irak.#
#.#.#.#.
.#.#.#.#
样例2:
#.#.#.#
rima.#.
mama#.#
.#.#.#.

// Problem#: 11157
// Submission#: 3719849
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <algorithm>
#include <iostream>
#include <string>
#include <cstdio>
#include <queue>
#include <cstring>
#include <vector>
#include <iomanip>
#include <map>
#include <stack>
#include <list>
using namespace std;
int main() {
    int n, m;
    cin >> n >> m;
    int u, l, r, d;
    cin >> u >> l >> r >> d;
    vector<vector<char> > b(n + u + d);
    for (int i = 0; i < b.size(); i++) {
        vector<char> line(m + l + r);
        b[i] = line;
    }
    for (int i = 0; i < b.size(); i++) {
        for (int j = 0; j < b[i].size(); j++) {
            if ((i + j) % 2) b[i][j] = '.';
            else b[i][j] = '#';
        }
    }
    for (int i = 0; i < n; i++) {
        string s;
        cin >> s;
        for (int j = 0; j < s.size(); j++) {
            b[u + i][l + j] = s[j];
        }
    }
    for (int i = 0; i < b.size(); i++) {
        for (int j = 0; j < b[i].size(); j++) {
            cout << b[i][j];
        }
        cout << endl;
    }
    return 0;
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值