Sicily 1936. Knight Moves

题目:

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy. Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.  

Input

There are multiple test cases. The first line contains an integer T, indicating the number of test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.  

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".  

Sample Input

8
e2 e4 
a1 b2 
b2 c3 
a1 h8 
a1 h7 
h8 a1 
b1 c3 
f6 f6  

Sample Output

To get from e2 to e4 takes 2 knight moves. 
To get from a1 to b2 takes 4 knight moves. 
To get from b2 to c3 takes 2 knight moves. 
To get from a1 to h8 takes 6 knight moves. 
To get from a1 to h7 takes 5 knight moves. 
To get from h8 to a1 takes 6 knight moves. 
To get from b1 to c3 takes 1 knight moves. 
To get from f6 to f6 takes 0 knight moves.
思路:

本题求最短路径,所以考虑用广度优先遍历。因为骑士只能走“日”字,所以从起点开始,将其能通过“日”字走到的点标记并加入队列,然后从队列中取出点进行下一轮遍历。直到队列为空,即可得到给定起点到其他所有点的最短路径。

代码:

#include <iostream>
#include <string>
#include <queue>
#include <memory.h>
using namespace std;

class Point {  
public:  
    int x;  
    int y;
    Point(int x, int y)
    {
        this->x = x;
        this->y = y;
    }
};  


int next_x[8] = {-2,-1,1,2,2,1,-1,-2};
int next_y[8] = {1,2,2,1,-1,-2,-2,-1};
int dis[9][9];

bool visited[9][9];
int start_x,start_y;
int end_x,end_y;

void bfs()
{
    if(start_x == end_x && start_y == end_y)
        return;
    queue<Point> q;
    q.push(Point(start_x,start_y));
    while(!q.empty())
    {
        Point temp = q.front();
        q.pop();
        for(int i = 0;i < 8;i++)
        {
            int x = temp.x + next_x[i];
            int y = temp.y + next_y[i];
            if(!visited[x][y] && x >=1 && y >= 1 && y <= 8 && x <= 8)
            {
                q.push(Point(x,y));
                visited[x][y] = true;
                dis[x][y] = dis[temp.x][temp.y] + 1;
            }
        }
    }
}

int main()
{
    int n;
    cin >> n;
    while(n--)
    {
        string s1,s2;
        cin >> s1 >> s2;
        start_x = s1[0] - 'a' + 1;
        start_y = s1[1] - '0';
        end_x = s2[0] - 'a' + 1;
        end_y = s2[1] - '0';
        
        memset(visited,false,sizeof(visited));
        memset(dis,0,sizeof(dis));
        visited[start_x][start_y] = true;
        bfs();

        cout << "To get from " << s1 << " to " << s2 << " takes "<< dis[end_x][end_y] << " knight moves." << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值