scau_10317 Fans of Footbal Teams(并查集)

10317 Fans of Footbal Teams

时间限制:1000MS  内存限制:65535K
提交次数:0 通过次数:0

题型: 编程题   语言: G++;GCC

Description

Two famous football teams, named AC Milan(AC米兰) and Inter Milan(国际米兰) will have a match in GuangZhou City, which is 
exciting. So a lot of fans get together to watch the wonderful match. This trouble the local polices. In order to avoid a 
chaos caused by fans of the two teams, the police office in GuangZhou City decides to arrange the seats of the gymnasium(体育馆) 
during the match. All fans of AC Milan seat Noth, while all fans of Inter Milan seat South . However, the police first needs 
to identify which team a fan support. The present question is, given two fans; do they support a same team? You must give 
your judgment based on incomplete information. 

Assume N (N <= 10^5) fans are currently in GuangZhou City, numbered from 1 to N. You will be given M (M <= 10^5) messages 
in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two fans, and they support different teams. 

2. A [a] [b] 
where [a] and [b] are the numbers of two fans. This requires you to decide whether a and b support a same team. 



输入格式

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. 
Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above. 


输出格式

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. 
The answers might be one of "Support the same team.", "Support different teams." and "Not sure yet."


输入样例

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4


输出样例

Not sure yet.
Support different teams.
Support the same team.
 
这道题我一开始没想到怎么用并查集做,后来才知道之前思维被局限了,其实可以把pre数组扩充一倍,让i+n表示i非,这样每次连通l和r+n,r和l+n,就能满足题意了。
 
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define Si(a) scanf("%d",&a)
#define Sl(a) scanf("%lld",&a)
#define Sd(a) scanf("%lf",&a)
#define Ss(a) scanf("%s",a)
#define Pi(a) printf("%d\n",(a))
#define Pl(a) printf("%lld\n",(a))
#define Pd(a) printf("%lf\n",(a))
#define Ps(a) printf("%s\n",(a))
#define W(a) while(a--)
#define mem(a,b) memset(a,(b),sizeof(a))
#define FOP freopen("data.txt","r",stdin)
#define inf 0x3f3f3f3f
#define maxn 1000010
#define mod 1000000007
#define PI acos(-1.0)
#define LL long long
using namespace std;

int pre[200010];
int find(int x)
{
    int r=x;
    while ( pre[r ] != r )
        r=pre[r ];

    int i=x , j ;
    while( i != r )
    {
        j = pre[ i ];
        pre[ i ]= r ;
        i=j;
    }
    return r ;
}


void join(int x,int y)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy)
        pre[fx ]=fy;
}

int main()
{
    int T;
    char c;
    int n,m,l,r,x;
    Si(T);
    while(T--)
    {
        Si(n),Si(m);
        for(int i=1;i<=2*n;i++)
        {
            pre[i]=i;
        }
        while(m--)
        {
            getchar();
            scanf("%c%d%d",&c,&l,&r);
            if(c=='D')
            {
                join(l,r+n);
                join(r,l+n);
            }
            else if(c=='A')
            {
                if(find(l)==find(r))
                {
                    puts("Support the same team.");
                }
                else if(find(l)==find(r+n))
                {
                    puts("Support different teams.");
                }
                else
                {
                    puts("Not sure yet.");
                }
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
该资源内项目源码是个人的课程设计、毕业设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。 该资源内项目源码是个人的课程设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值