poj_1753 Flip Game(dfs+枚举)/(bfs+位运算)

16 篇文章 0 订阅
10 篇文章 0 订阅
Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40897 Accepted: 17756

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4
题目中棋盘一共有16个格子,每个格子有白和黑两种情况,可知枚举最多有2^16种可能。
所以说事实上每个格子最多只需要一次操作,因为重复两次操作会得到原来的状态,所以最多只需走16步。
可以分16步深搜状态树,直到得到题目所要求的状态,最后输出树的深度,如果超过16步则没有解。
 
 
 
也可以用一个16位的整数来表示棋盘的状态,用异或运算(^)来更新状态,再用一个标志数组来保存某个状态是否已经出现过。
然后用bfs思想将状态存入队列中,如果已经是题目要求的状态,则输出达到该状态所要走的步数,
这里可以用一个新的数组来保存达到每个状态的步数。如果不是要求的状态,且是新的状态,则加入数组。
因为状态数是一定的,所以如果该棋盘没有解,则到最后所有的状态都标志完,队列一定会为空,
此时跳出循环输出Impossible。
 
dfs+枚举
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define FOP freopen("data.txt","r",stdin)
#define inf 0x3f3f3f3f
#define maxn 1000010
#define mod 1000000007
#define PI acos(-1.0)
#define LL long long
using namespace std;

int a[6][6];
int res;
int flag = 0;

int judge()
{

    for(int i = 1; i <= 4; i++)
    {
        for(int j = 1; j <= 4; j++)
        {
            if(a[i][j] != a[1][1])
                return 0;
        }
    }
    return 1;
}

void dfs(int ans, int i, int j)
{
    if(ans == res)
    {
        if(judge())flag = 1;
        return ;
    }
    if(i > 4)return ;

    a[i][j] = !a[i][j];
    a[i-1][j] = !a[i-1][j];
    a[i+1][j] = !a[i+1][j];
    a[i][j-1] = !a[i][j-1];
    a[i][j+1] = !a[i][j+1];

    if(j < 4)
        dfs(ans + 1, i, j + 1);
    else
        dfs(ans + 1, i + 1, 1);

    a[i][j] = !a[i][j];
    a[i-1][j] = !a[i-1][j];
    a[i+1][j] = !a[i+1][j];
    a[i][j-1] = !a[i][j-1];
    a[i][j+1] = !a[i][j+1];

    if(j < 4)
        dfs(ans, i, j + 1);
    else
        dfs(ans, i + 1, 1);

    return ;
}
int main()
{
    char s[10];

    for(int i = 1; i <= 4; i++)
    {
        scanf("%s", s+1);

        for(int j = 1; j <= 4; j++)
        {
            if(s[j] == 'b') a[i][j] = 1;
            else    a[i][j] = 0;
        }
    }

    for(res = 0; res <= 16; res++)
    {
        dfs(0, 1, 1);
        if(flag) break;
    }
    if(!flag)printf("Impossible\n");
    else printf("%d\n", res);

    return 0;
}


 
bfs+位运算
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define FOP freopen("data.txt","r",stdin)
#define inf 0x3f3f3f3f
#define maxn 1<<16
#define mod 1000000007
#define PI acos(-1.0)
#define LL long long
using namespace std;

queue<int> Q;
bool vis[maxn];
int step[maxn];
int ans;
bool flag = false;

void bfs(int n)
{
    if(n == 0 || n == (1<<16) - 1)
    {
       ans = 0;
       flag = true;
       return ;
    }
    step[n] = 0;
    Q.push(n);
    vis[n] = true;
    while(!Q.empty())
    {
        int temp = Q.front();
        //printf("%d\n", temp);
        Q.pop();
        for(int i = 0; i < 16; i++)
        {
            int t = temp;

            t ^= 1<<(15 - i);

            if(i % 4 == 0) t ^= 1<<(14 - i);
            else if(i % 4 == 3) t ^= 1<<(16 - i);
            else t ^= 5<<(14 - i);

            if(i <= 3) t ^= 1<<(15 - i - 4);
            else if(i >= 12) t ^= 1<<(15 - i + 4);
            else {t ^= 1<<(15 - i - 4); t ^= 1<<(15 - i + 4);}

            if(t == 0 || t == (1<<16) - 1)
            {
                ans = step[temp] + 1;
                flag = true;
                return ;
            }

            if(!vis[t])
            {
                Q.push(t);
                step[t] = step[temp] + 1;
                vis[t] = true;
            }
        }
    }

}

int main()
{
    int id = 0;
    char s[5];
    for(int i = 1; i <= 4; i++)
    {
        scanf("%s", s);
        for(int j = 0; j < 4; j++)
        {
            id <<= 1;
            if(s[j] == 'b')id += 1;
        }
    }
    memset(vis, false, sizeof(vis));
    bfs(id);
    if(!flag) printf("Impossible\n");
    else printf("%d\n", ans);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值