bestcode ——连续字符统计

Find Q

 
 Accepts: 599
 
 Submissions: 778
 Time Limit: 2000/1000 MS (Java/Others)
 
 Memory Limit: 262144/131072 K (Java/Others)
Problem Description

Byteasar is addicted to the English letter 'q'. Now he comes across a string SS consisting of lowercase English letters.

He wants to find all the continous substrings of SS, which only contain the letter 'q'. But this string is really really long, so could you please write a program to help him?

Input

The first line of the input contains an integer T(1\leq T\leq10)T(1T10), denoting the number of test cases.

In each test case, there is a string SS, it is guaranteed that SS only contains lowercase letters and the length of SS is no more than 100000100000.

Output

For each test case, print a line with an integer, denoting the number of continous substrings of SS, which only contain the letter 'q'.

Sample Input
2
qoder
quailtyqqq
Sample Output
1
7


统计连续的q,然后加上(n-1)*n/2

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <climits>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <list>
#define rep(i,m,n) for(i=m;i<=n;i++)
#define rsp(it,s) for(set<int>::iterator it=s.begin();it!=s.end();it++)
#define mod 2009
#define INF 9999999999999
#define vi vector<int>
#define pb push_back
#define mp make_pair
#define fi first
#define se second
#define pi acos(-1.0)
#define pii pair<int,int>
#define Lson L, mid, rt<<1
#define Rson mid+1, R, rt<<1|1
const int maxn=5e2+10;
using namespace std;
typedef  long long ll;
ll gcd(ll p,ll q){return q==0?p:gcd(q,p%q);}
ll qpow(ll p,ll q){ll f=1;while(q){if(q&1)f=f*p;p=p*p;q>>=1;}return f;}
ll my_min(ll x,ll y){ return x>y?y:x;};

int main()
{
	int t;
	char str[100005];
	while(scanf("%d",&t)!=EOF)
	{
		for(int i=1;i<=t;i++)
		{
			unsigned long long re = 0;
			memset(str,0,sizeof(str));
			scanf("%s",str);
			int len = strlen(str);
			int k;
			for(int j=0;j<len;j++)	
			{
				if(str[j]=='q')
				{
					k=0; 
					while(str[j]=='q')
					{
						k++;
						j++;
					}
					unsigned long long t1 = 0;
					for(int l=1;l<=k;l++)
					{
						t1 +=l;
					} 
					re+=t1;
					j--;
				}
			}
			printf("%llu\n",re);
		}	
	}
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值