1064 Complete Binary Search Tree (30)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4
#include<cstdio>
#include<fstream>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn=110;

struct node{
	int data;
	int lchild, rchild;
}Node[maxn];

int n, in[maxn], num=0;


void inorder(int root){
	if(root==-1) return;
	inorder(Node[root].lchild);
	Node[root].data=in[num++];
	inorder(Node[root].rchild);
}

void BFS(int root){
	queue<int> q;
	q.push(root);
	num=0;
	while(!q.empty()){
		int now=q.front();
		q.pop();
		printf("%d", Node[now].data);
		num++;
		if(num<n) printf(" ");
		if(Node[now].lchild!=-1) q.push(Node[now].lchild);
		if(Node[now].rchild!=-1) q.push(Node[now].rchild);  
	}
}

int main(){
	int lchild, rchild;
//	freopen("d://in.txt","r",stdin);
	scanf("%d", &n);
	for(int i=0; i<n; i++){
		scanf("%d%d", &lchild, &rchild);
		Node[i].lchild=lchild;
		Node[i].rchild=rchild;
	}
	for(int i=0; i<n; i++){
		scanf("%d", &in[i]);
	}
	sort(in, in+n);
	inorder(0);
	BFS(0);
	return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值