poj 3468 A Simple Problem with Integers

A Simple Problem with Integers

Time Limit: 5000MS Memory Limit: 131072K
Case Time Limit: 2000MS

这里是题目链接


Description

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.


嗯……线段树的成段更新以及区间求和,主要就是在更新的时候并不全部加到每个节点上,而是加到对应区间的父节点上,并做mark标记,而当query到相关子节点时,再将相应的mark加到子节点上,并分别更新父节点和子节点的mark。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <cmath>
#include <string>
#include <queue>
#include <stack>
#define INF 0x3f3f3f3f
#define mem(x,y) memset(x,y,sizeof(x))
#define SI(x) scanf("%d",&x)
#define MAX 100000+10

using namespace std;
typedef long long ll;

int a[MAX];
struct node{
    int left,right,mid;
    ll sum,mark;
}b[MAX<<2];

void build(int left,int right,int i)
{
    b[i].left=left;
    b[i].right=right;
    b[i].mark=0;
    b[i].mid=(right+left)>>1;
    int mid;
    if(left==right)
    {
        b[i].sum=a[left];
        return;
    }
    mid=(right+left)>>1;
    build(left,mid,i<<1);
    build(mid+1,right,(i<<1)+1);
    b[i].sum=b[i<<1].sum+b[(i<<1)+1].sum;
}

void add(int left,int right, int num,int i)
{
    if(b[i].left==left&&b[i].right==right)
    {
      //  b[i].sum+=num;
      b[i].mark+=num;
      return;
    }else {
        b[i].sum+=(ll)num*(right-left+1);
//        int mid ;
//        mid= (b[i].right+ b[i].left)>>1;
        if(right<=b[i].mid) add(left,right,num,i<<1);
        else if(left>b[i].mid) add(left,right,num,(i<<1)+1);
        else{
            add(left,b[i].mid,num,i<<1);
            add(b[i].mid+1,right,num,(i<<1)+1);
        }
    }
}

ll query(int left,int right,int i)
{
   // int mid;
    if(b[i].left==left&&b[i].right==right) return b[i].sum+b[i].mark*(ll)(right-left+1);
    if(b[i].mark!=0){
        b[i<<1].mark+=b[i].mark;
        b[(i<<1)+1].mark+=b[i].mark;
        b[i].sum+=(ll)(b[i].right-b[i].left+1)*b[i].mark;
        b[i].mark=0;
    }
 //   mid=(b[i].left+b[i].right)>>1;
    if(right<=b[i].mid) return query(left,right,i<<1);
    else if(left>b[i].mid) return query(left,right,(i<<1)+1);
    else return query(left,b[i].mid,i<<1)+query(b[i].mid+1,right,(i<<1)+1);
}

int main()
{
    int n,q,l,r,val;
    char str[10];
    while(scanf("%d%d",&n,&q)!=EOF)
    {
        for(int i=1;i<=n;i++)
            SI(a[i]);
        build(1,n,1);
        for(int i=0;i<q;i++)
        {
            scanf("%s",str);
            if(str[0]=='Q'){
                scanf("%d%d",&l,&r);
                printf("%lld\n",query(l,r,1));
            }else{
                scanf("%d%d%d",&l,&r,&val);
                add(l,r,val,1);
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值