poj 3254 Corn Fields(状压dp)

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can’t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
4
There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

其实思路是很好想的,将每一行的情况用一个二进制数表示,然后按列进行dp就可以了,可以先把每一行的情况处理出来存入一个数组中,然后用位运算就可以判断了……看题解的时候真的觉得位运算减轻工作量啊……

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <string>
#include <cstdio>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))
#define maxn 35
#define mod 100000000

int n,m;
int dp[1<<13][13];
int g[20][20];
int a[20];

int check(int x,int s)
{
    if((a[x]&s)!=s) return 0;
    if((s&(s<<1))!=0||(s&(s>>1))!=0) return 0;
    return 1;
}

void solve()
{
    int ans=0;
    dp[0][0]=1;
    for(int i=1;i<=m;i++)
    {
        for(int s=0;s<(1<<n);s++)
        {
            if(!check(i,s)) continue;

            for(int ss=0;ss<(1<<n);ss++)
            {
                if((s&ss)!=0) continue;
                dp[s][i]=(dp[s][i]+dp[ss][i-1])%mod;
            }
            ans=(ans+dp[s][m])%mod;
        }
    }
    cout<<ans<<endl;
}

int main ()
{
    cin>>m>>n;
    for(int i=1;i<=m;i++)
    {
        a[i]=0;
        for(int j=0;j<n;j++)
        {
            int x;
            cin>>x;
            a[i]=(a[i]<<1)+x;
        }
    }

    solve();
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值