Type Dynamic Web Module 4.0 requires Java 1.8 or newer----彻底杀死Bug

版权声明:未经允许,不得转载 https://blog.csdn.net/cincoutcin/article/details/85096155

0、确定要修改到的地方:(个人jdk版本是1.8)

0、1Project Facets

0、2Java Build Path ----Library

0、3Java Compiler

0、4.setting文件

0、5pom.xml文件添加jdk版本限制

 

1、Project Facets

右键项目----Properties----Maven

 

2、Java Build Path ----Library

右键项目-----Build Path-----Configure Build Path----Libraries

删除非要求版本的jdk然后 Add Library,添加自己的jdk版本

Li

 

3、Java Compiler

项目右键----Properties

 

4、.setting文件

1、打开Navigator视图

5、pom.xml,添加jdk版本

	<build>
		<plugins>
			<plugin>
				<groupId>org.apache.maven.plugins</groupId>
				<artifactId>maven-compiler-plugin</artifactId>
				<version>3.0</version>
				<configuration>
					<source>1.8</source>
					<target>1.8</target>
				</configuration>
			</plugin>
		</plugins>
	</build>

maven update项目,杀死bug

展开阅读全文

没有更多推荐了,返回首页