九度[1042]-Coincidence

九度[1042]-Coincidence

题目描述:
Find a longest common subsequence of two strings.

输入
First and second line of each input case contain two strings of lowercase character a…z. There are no spaces before, inside or after the strings. Lengths of strings do not exceed 100.

输出
For each case, output k – the length of a longest common subsequence in one line.

样例输入
abcd
cxbydz

样例输出
2

解题思路:
动态规划的经典题目:最长公共子序列(LCS)
注意读取的字符串以及对应的长度。

AC代码:

#include <cstdio>
#include <cstring>
#define max(a,b) a>b?a:b;
const int maxn = 110;
char dat1[maxn], dat2[maxn];
int ans[maxn][maxn];

void init(){
    for(int i = 0; i < maxn; i++){
        for(int j = 0; j < maxn; j++){
            ans[i][j] = 0;
        }
    }
}

int main(){
    freopen("C:\\Users\\Administrator\\Desktop\\test.txt", "r", stdin);
    while(scanf("%s%s", dat1+1, dat2+1) != EOF){
        init();
        int len1 = strlen(dat1+1), len2 = strlen(dat2+1);
        int cnt1 = 1, cnt2 = 1;
        for(int i = 1; i <= len1; i++){
            for(int j = 1; j <= len2; j++){
                if(dat1[i] == dat2[j]){
                    ans[i][j] = ans[i-1][j-1] + 1;
                }
                else ans[i][j] = max(ans[i-1][j], ans[i][j-1]);
            }
        }
        printf("%d\n", ans[len1][len2]);
    }
    fclose(stdin);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值