九度1124:digital root

题目1124:Digital Roots

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:5513

解决:1852

题目描述:

    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

输入:

    The input file will contain a list of positive integers, one per line. 
    The end of the input will be indicated by an integer value of zero.

输出:

    For each integer in the input, output its digital root on a separate line of the output.

样例输入:
24
39
0
样例输出:
6
3
提示:

The integer may consist of a large number of digits.

来源:
2008年北京大学treble
方正实验室计算机研究生机试真题
*************************************
 一遍AC的题
这道题就是不断地分割,相加,判断........但有一个点需要注意,重新拆分sum时,结尾别忘了添上‘\0’,使字符串结尾,否则可能因为buf里存的是上次的数据(位数更多)导致出错。
#include <cstdio>
#include <cstring>
using namespace std;
char buf[100]={0};
void chai(int n)
{
    int i=0;
    while(n!=0){
        buf[i++]=n%10+'0';
        n/=10;
    }
    buf[i]='\0';
}
int main()
{
    while(scanf("%s",buf)!=EOF){
        int len=strlen(buf),sum=0;
        if(buf[0]=='0'&&len==1)   return 0;
        while(1){
            for(int i=0;i<len;i++)
                sum+=(buf[i]-'0');
            if(sum>=0&&sum<=9){
                printf("%d\n",sum);
                break;
            }
            chai(sum);
            len=strlen(buf);sum=0;
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值