Description
你手中有一份交大的地图来帮助你去上课。交大的地形十分复杂,有四种地形: (你只能上下左右移动)
通路 ”.”:可以上下左右移动; (英文句号 . )
桥 ”|”:只能上下移动; (C++中的或 | )
桥 ”-“:只能左右移动; (减号)
墙 “*“: 不能通行。 (乘号)
现在你在地图上的(x1, y1)位置,上课地点在(x2, y2)处,请你帮你找出一条路径去上课。由于时间紧迫,你希望知道他所在的位置离上课地点有多远。你只需输出小明当前位置离上课地点的最短距离。如果无法到达上课地点,请输出-1。输入数据保证起点和终点是通路 “.“
Input Format
第1行: n, m 给出交大地图的长和宽,用空格分隔
第2行: x1, y1, x2, y2 给出小明的位置(x1, y1) 和目的地(x2, y2),每两个数中间用空格分隔。x表示行,y表示列。
第3到n+2行: 每行m个字符,描述了交大的地形。每个字符之间没有空格。
Output Format
一行,输出最短距离。
数据范围
对于100%的数据,n,m<=100.
Sample Input
4 5
2 2 3 4
…
….
.…
…
Sample Output
7
Sample Input
4 5
1 3 2 5
…-|
.|.
.|-.
…-.
Sample Output
7
Sample Input
3 3
1 3 3 1
..
.
..
Sample Output
-1
Sample Input
2 2
1 1 2 2
.
|.
Sample Output
-1
#include <iostream>
#include <queue>
using namespace std;
struct node {
int x;
int y;
int len;
};
queue<node> q;
int main() {
int n, m, x1, y1, x2, y2;
char arr[105][105];
bool pass[105][105] = { false };
int xx[4] = { 1,0,0,-1 };//下、右、左、上
int yy[4] = { 0,1,-1,0 };
int re = -1;
cin >> n >> m >> x1 >> y1 >> x2 >> y2;
char tmp;
for (int i = 1; i <= n; i++) {
for (int j = 1; j <= m; j++) {
cin >> arr[i][j];
}
}
node s;
s.x = x1;
s.y = y1;
s.len = 0;
q.push(s);
pass[x1][y1] = true;
while (!q.empty())
{
node now = q.front();
q.pop();
for (int i = 0; i < 4; ++i)
{
if (i == 0 || i == 3) {
if (arr[now.x][now.y] == '-') continue;
}
if (i == 1 || i == 2) {
if (arr[now.x][now.y] == '|') continue;
}
node New;
New.x = now.x + xx[i];
New.y = now.y + yy[i];
New.len = now.len + 1;
if (New.x<1 || New.y<1 || New.x>n || New.y>m || pass[New.x][New.y] || arr[New.x][New.y] == '*')
continue;
if (i == 0 || i == 3) {
if (arr[New.x][New.y] == '-') continue;
}
if (i == 1 || i == 2) {
if (arr[New.x][New.y] == '|') continue;
}
q.push(New);
pass[New.x][New.y] = true;
if (New.x == x2 && New.y == y2) {
cout << New.len;
return 0;
}
}
}
cout << -1;
return 0;
}