杭电oj 1006 Tick and Tick

Tick and Tick

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18985    Accepted Submission(s): 4871


Problem Description
The three hands of the clock are rotating every second and meeting each other many times everyday. Finally, they get bored of this and each of them would like to stay away from the other two. A hand is happy if it is at least D degrees from any of the rest. You are to calculate how much time in a day that all the hands are happy.
 

Input
The input contains many test cases. Each of them has a single line with a real number D between 0 and 120, inclusively. The input is terminated with a D of -1.
 

Output
For each D, print in a single line the percentage of time in a day that all of the hands are happy, accurate up to 3 decimal places.
 

Sample Input
  
  
0 120 90 -1
 

Sample Output
  
  
100.000 0.000 6.251
 

Author
PAN, Minghao
 

Source
 


#include<iostream>
#include<iomanip>
#include<cstdio>
//#define LOCAL
using namespace std;
double max(double a,double b,double c)
{
    return a>b?(a>c?a:c):(b>c?b:c);
}

double min(double a,double b,double c)
{
    return a<b?(a<c?a:c):(b<c?b:c);
}

int main(int argc,char **argv)
{
    #ifdef LOCAL
        freopen("data.in","r",stdin);
        freopen("data.out","w",stdout);
    #endif
    int n; 
    //相差一度所要的时间
    double sm = 10./59.;
    double mh = 120./11.;
    double sh = 120./719.;
    //相差360度所要的时间
    double _360sm = sm*360;
    double _360mh = mh*360;
    double _360sh = sh*360;
    //快乐的总时间
    double sum;
    //快乐的开始时间和结束时间
    double start_happy,end_happy;
    //相差n度所要的时间,以及不再相差n度以上相差的时间
    double _nsm,_nsh,_nmh,not_nsm,not_nsh,not_nmh;
    while(cin>>n)
    {
        if(n==-1)
            break;
        sum = 0;
        _nsm = n*sm;
        _nsh = n*sh;
        _nmh = n*mh;
        not_nsm = _360sm-_nsm;
        not_nsh = _360sh-_nsh;
        not_nmh = _360mh-_nmh;
        start_happy = max(_nsm,_nsh,_nmh);
        end_happy = min(not_nsm,not_nsh,not_nmh);
        while(start_happy<=43200&&end_happy<=43200)
        {
            start_happy = max(_nsm,_nsh,_nmh);
            end_happy = min(not_nsm,not_nsh,not_nmh);
            if(start_happy<end_happy)
                sum += end_happy - start_happy;
            if(end_happy == not_nsm)
            {
                _nsm += _360sm;
                not_nsm += _360sm;
            }else if(end_happy == not_nsh)
            {
                _nsh += _360sh;
                not_nsh += _360sh;
            }else{
                _nmh += _360mh;
                not_nmh += _360mh;
            }
        }
        printf("%.3lf\n",sum/43200*100);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值