杭电oj 1006

先看题目

Tick and Tick

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15584    Accepted Submission(s): 3683


Problem Description
The three hands of the clock are rotating every second and meeting each other many times everyday. Finally, they get bored of this and each of them would like to stay away from the other two. A hand is happy if it is at least D degrees from any of the rest. You are to calculate how much time in a day that all the hands are happy.
 


Input
The input contains many test cases. Each of them has a single line with a real number D between 0 and 120, inclusively. The input is terminated with a D of -1.
 


Output
For each D, print in a single line the percentage of time in a day that all of the hands are happy, accurate up to 3 decimal places.
 


Sample Input
  
  
0 120 90 -1
 


Sample Output
  
  
100.000 0.000 6.251
 题目看了半天没看懂,不说了,说多了都是泪。
题目的大概意思就是输入一个角度,然后输出一个比例,这个比例代表三个钟表指针最小为那个的角度的时间之和和总时间的比值。以一天的时间计算。
题目不难但是会很繁琐,反正需要很小心的计算,自己画画图就能够理解了。
我们需要先算出表针,分针和时针的速度,然后计算他们速度差,这样就能计算出他们1s的时间他们之间的角度相差多少,然后就可以计算出时间了。
我的代码,
#include <iostream>
#include <cstdio>
using namespace std;
double max1(double a,double b,double c)
{
	 if(a<b) a=b;
	 if(a<c) a=c;
	 return a;
}
double min1(double a,double b,double c)
{
	 if(a>b) a=b;
	 if(a>c) a=c;
	 return a;
 }
 inline bool equal1(double a,double b)
 {
	if((a-b)>-0.0000001&&(a-b)<0.0000001) 
	 	return true;
	else 
		return false;
}
int main(){
	double sum=0.0,d,newx,newy;
	double mh=43200.0000/11;
	double sm=3600.0000/59;
	double sh=43200.0000/719;
	double dsm,dsh,dmh,tdsm,tdsh,tdmh;
	cin>>d;
	while(d!=-1){
		sum=0.0;
		dsm=10.0*d/59.0;  tdsm=sm-dsm;
		dsh=120.0*d/719.0;	 tdsh=sh-dsh;
		dmh=120.0*d/11.0;	 tdmh=mh-dmh;
		newx=max1(dsm,dsh,dmh); newy=min1(tdsm,tdsh,tdmh);
		while(newx<=43200&&newy<=43200)
		{
			newx=max1(dsm,dsh,dmh);  		
			newy=min1(tdsm,tdsh,tdmh);   	
			if(newx<newy) 
				sum+=newy-newx; 
			if(newy==tdsm) 
			{
				dsm+=sm;
				tdsm+=sm;
			}
			else if(newy==tdsh) 
			{
				dsh+=sh;
				tdsh+=sh;
			}
			else if(newy==tdmh)
			{
				dmh+=mh;
				tdmh+=mh;
			}
		}
		
		printf("%.3lf\n",sum/432);
		cin>>d;
	}
	return 0;
}
ac了

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值